aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/armada-3720-db.bootscript10
-rw-r--r--target/linux/mvebu/image/cortex-a53.mk13
2 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/armada-3720-db.bootscript b/target/linux/mvebu/image/armada-3720-db.bootscript
new file mode 100644
index 0000000000..65e39a1af5
--- /dev/null
+++ b/target/linux/mvebu/image/armada-3720-db.bootscript
@@ -0,0 +1,10 @@
+setenv bootargs "root=PARTUUID=@ROOT@-02 rw rootwait"
+
+if test -n "${console}"; then
+ setenv bootargs "${bootargs} ${console}"
+fi
+
+load mmc 0:1 ${fdt_addr} armada-3720-db.dtb
+load mmc 0:1 ${kernel_addr} Image
+
+booti ${kernel_addr} - ${fdt_addr}
diff --git a/target/linux/mvebu/image/cortex-a53.mk b/target/linux/mvebu/image/cortex-a53.mk
index 711d2c0be8..89c3363448 100644
--- a/target/linux/mvebu/image/cortex-a53.mk
+++ b/target/linux/mvebu/image/cortex-a53.mk
@@ -13,4 +13,17 @@ define Device/globalscale-espressobin
endef
TARGET_DEVICES += globalscale-espressobin
+define Device/armada-3720-db
+ KERNEL_NAME := Image
+ KERNEL := kernel-bin
+ DEVICE_TITLE := Marvell Armada 3720 Development Board DB-88F3720-DDR3
+ DEVICE_PACKAGES := e2fsprogs ethtool mkf2fs kmod-fs-vfat kmod-usb2 kmod-usb3 kmod-usb-storage
+ IMAGES := sdcard.img.gz
+ IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
+ DEVICE_DTS := armada-3720-db
+ DTS_DIR := $(DTS_DIR)/marvell
+ SUPPORTED_DEVICES := marvell,armada-3720-db
+endef
+TARGET_DEVICES += armada-3720-db
+
endif