aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile12
-rw-r--r--target/linux/mvebu/image/cfpro-boot.script (renamed from target/linux/mvebu/image/boot.script)2
2 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index f4635dd1bf..dcbf4a67b3 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -23,9 +23,9 @@ endef
# Partition 1: 32768 sectors
# Partition 2: 98304 sectors (configurable)
-define Build/boot-scr
+define Build/boot-scr-cfpro
rm -f $@.bootscript
- mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d boot.script $@.bootscript
+ mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d cfpro-boot.script $@.bootscript
endef
define Build/boot-img
@@ -171,16 +171,16 @@ define Device/armada-388-rd
endef
TARGET_DEVICES += armada-388-rd
-define Device/armada-388-clearfog
+define Device/armada-388-clearfog-pro
KERNEL_INSTALL := 1
KERNEL := dtb | kernel-bin
- DEVICE_TITLE := SolidRun ClearFog
+ DEVICE_TITLE := SolidRun ClearFog Pro
DEVICE_PACKAGES := mkf2fs e2fsprogs swconfig kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
IMAGES := sdcard.img.gz
- IMAGE/sdcard.img.gz := boot-scr | boot-img | sdcard-img | gzip | append-metadata
+ IMAGE/sdcard.img.gz := boot-scr-cfpro | boot-img | sdcard-img | gzip | append-metadata
IMAGE_NAME = $$(IMAGE_PREFIX)-$$(2)
endef
-TARGET_DEVICES += armada-388-clearfog
+TARGET_DEVICES += armada-388-clearfog-pro
define Device/globalscale-mirabox
$(Device/NAND-512K)
diff --git a/target/linux/mvebu/image/boot.script b/target/linux/mvebu/image/cfpro-boot.script
index 1ebc88bda3..6f7653bace 100644
--- a/target/linux/mvebu/image/boot.script
+++ b/target/linux/mvebu/image/cfpro-boot.script
@@ -2,6 +2,6 @@ setenv bootargs console=ttyS0,115200n8 root=/dev/mmcblk0p2 rootfstype=squashfs r
setenv fdt_high 0x07a12000
fatload mmc 0:1 0x02000000 zImage
-fatload mmc 0:1 0x05F00000 armada-388-clearfog.dtb
+fatload mmc 0:1 0x05F00000 armada-388-clearfog-pro.dtb
bootz 0x02000000 - 0x05F00000