aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/octeon/image/Makefile')
-rw-r--r--target/linux/octeon/image/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index 11da22df3b..f77159e1f9 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -51,17 +51,28 @@ define Device/ubnt_edgerouter
endef
TARGET_DEVICES += ubnt_edgerouter
-define Device/ubnt_edgerouter-4
+define Device/ubnt_edgerouter-e300
DEVICE_VENDOR := Ubiquiti
- DEVICE_MODEL := EdgeRouter 4
- DEVICE_DTS := cn7130_ubnt_edgerouter-4
DEVICE_PACKAGES += kmod-gpio-button-hotplug kmod-leds-gpio kmod-of-mdio kmod-sfp kmod-usb3 kmod-usb-dwc3 kmod-usb-storage-uas
KERNEL := kernel-bin | patch-cmdline | append-dtb-to-elf
KERNEL_DEPENDS := $$(wildcard $(DTS_DIR)/$(DEVICE_DTS).dts)
CMDLINE := root=/dev/mmcblk0p2 rootfstype=squashfs,ext4 rootwait
endef
+
+define Device/ubnt_edgerouter-4
+ $(Device/ubnt_edgerouter-e300)
+ DEVICE_MODEL := EdgeRouter 4
+ DEVICE_DTS := cn7130_ubnt_edgerouter-4
+endef
TARGET_DEVICES += ubnt_edgerouter-4
+define Device/ubnt_edgerouter-6p
+ $(Device/ubnt_edgerouter-e300)
+ DEVICE_MODEL := EdgeRouter 6P
+ DEVICE_DTS := cn7130_ubnt_edgerouter-6p
+endef
+TARGET_DEVICES += ubnt_edgerouter-6p
+
ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0)ro,512k(boot1)ro,64k(eeprom)ro root=/dev/sda2 rootfstype=squashfs,ext4 rootwait
define Device/ubnt_edgerouter-lite
DEVICE_VENDOR := Ubiquiti