aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.14
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/oxnas/patches-4.14')
-rw-r--r--target/linux/oxnas/patches-4.14/320-oxnas-phy-pcie.patch44
-rw-r--r--target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch24
-rw-r--r--target/linux/oxnas/patches-4.14/500-oxnas-sata.patch2
3 files changed, 60 insertions, 10 deletions
diff --git a/target/linux/oxnas/patches-4.14/320-oxnas-phy-pcie.patch b/target/linux/oxnas/patches-4.14/320-oxnas-phy-pcie.patch
new file mode 100644
index 0000000000..7dc9470424
--- /dev/null
+++ b/target/linux/oxnas/patches-4.14/320-oxnas-phy-pcie.patch
@@ -0,0 +1,44 @@
+--- a/arch/arm/boot/dts/ox820.dtsi
++++ b/arch/arm/boot/dts/ox820.dtsi
+@@ -246,6 +246,15 @@
+ };
+ };
+
++ pcie_phy: pcie-phy@a00000 {
++ compatible = "oxsemi,ox820-pcie-phy";
++ reg = <0xa00000 0x10>;
++ #phy-cells = <0>;
++ resets = <&reset RESET_PCIEPHY>;
++ reset-names = "phy";
++ status = "disabled";
++ };
++
+ sys: sys-ctrl@e00000 {
+ compatible = "oxsemi,ox820-sys-ctrl", "syscon", "simple-mfd";
+ reg = <0xe00000 0x200000>;
+--- a/drivers/phy/Kconfig
++++ b/drivers/phy/Kconfig
+@@ -26,6 +26,13 @@ config PHY_LPC18XX_USB_OTG
+ This driver is need for USB0 support on LPC18xx/43xx and takes
+ care of enabling and clock setup.
+
++config PHY_OXNAS
++ tristate "Oxford Semi. OX820 PCI-E PHY support"
++ depends on HAS_IOMEM && OF && (ARM || COMPILE_TEST)
++ select GENERIC_PHY
++ help
++ This option enables support for OXNAS OX820 SoC PCIE PHY.
++
+ config PHY_PISTACHIO_USB
+ tristate "IMG Pistachio USB2.0 PHY driver"
+ depends on MACH_PISTACHIO
+--- a/drivers/phy/Makefile
++++ b/drivers/phy/Makefile
+@@ -5,6 +5,7 @@
+
+ obj-$(CONFIG_GENERIC_PHY) += phy-core.o
+ obj-$(CONFIG_PHY_LPC18XX_USB_OTG) += phy-lpc18xx-usb-otg.o
++obj-$(CONFIG_PHY_OXNAS) += phy-oxnas-pcie.o
+ obj-$(CONFIG_PHY_XGENE) += phy-xgene.o
+ obj-$(CONFIG_PHY_PISTACHIO_USB) += phy-pistachio-usb.o
+ obj-$(CONFIG_ARCH_SUNXI) += allwinner/
diff --git a/target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch b/target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch
index 4681888da0..16f47d9056 100644
--- a/target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch
+++ b/target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch
@@ -22,7 +22,7 @@
--- a/arch/arm/boot/dts/ox820.dtsi
+++ b/arch/arm/boot/dts/ox820.dtsi
-@@ -307,6 +307,83 @@
+@@ -316,6 +316,89 @@
reg = <0x1000 0x1000>,
<0x100 0x500>;
};
@@ -41,8 +41,11 @@
+
+ bus-range = <0x00 0x7f>;
+
-+ /* cfg inbound translator phy*/
-+ reg = <0x47C00000 0x1000>, <0x47D00000 0x100>, <0x44A00000 0x10>;
++ /* cfg inbound translator */
++ reg = <0x0 0x1000>, <0x100000 0x100>;
++
++ phys = <&pcie_phy>;
++ phy-names = "pcie-phy";
+
+ #interrupt-cells = <1>;
+ /* wild card mask, match all bus address & interrupt specifier */
@@ -56,8 +59,8 @@
+ gpios = <&gpio1 12 0>;
+ clocks = <&stdclk CLK_820_PCIEA>, <&pllb>;
+ clock-names = "pcie", "busclk";
-+ resets = <&reset RESET_PCIEA>, <&reset RESET_PCIEPHY>;
-+ reset-names = "pcie", "phy";
++ resets = <&reset RESET_PCIEA>;
++ reset-names = "pcie";
+
+ plxtech,pcie-hcsl-bit = <2>;
+ plxtech,pcie-ctrl-offset = <0x120>;
@@ -79,8 +82,11 @@
+
+ bus-range = <0x80 0xff>;
+
-+ /* cfg inbound translator phy*/
-+ reg = <0x47E00000 0x1000>, <0x47F00000 0x100>, <0x44A00000 0x10>;
++ /* cfg inbound translator */
++ reg = <0x0 0x1000>, <0x100000 0x100>;
++
++ phys = <&pcie_phy>;
++ phy-names = "pcie-phy";
+
+ #interrupt-cells = <1>;
+ /* wild card mask, match all bus address & interrupt specifier */
@@ -94,8 +100,8 @@
+ /* gpios = <&gpio1 12 0>; */
+ clocks = <&stdclk CLK_820_PCIEB>, <&pllb>;
+ clock-names = "pcie", "busclk";
-+ resets = <&reset RESET_PCIEB>, <&reset RESET_PCIEPHY>;
-+ reset-names = "pcie", "phy";
++ resets = <&reset RESET_PCIEB>;
++ reset-names = "pcie";
+
+ plxtech,pcie-hcsl-bit = <3>;
+ plxtech,pcie-ctrl-offset = <0x124>;
diff --git a/target/linux/oxnas/patches-4.14/500-oxnas-sata.patch b/target/linux/oxnas/patches-4.14/500-oxnas-sata.patch
index f79b100a5e..7aa0df973f 100644
--- a/target/linux/oxnas/patches-4.14/500-oxnas-sata.patch
+++ b/target/linux/oxnas/patches-4.14/500-oxnas-sata.patch
@@ -26,7 +26,7 @@
obj-$(CONFIG_PATA_ALI) += pata_ali.o
--- a/arch/arm/boot/dts/ox820.dtsi
+++ b/arch/arm/boot/dts/ox820.dtsi
-@@ -385,5 +385,20 @@
+@@ -400,5 +400,20 @@
};
};