aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/profiles/100-Generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/oxnas/profiles/100-Generic.mk')
-rw-r--r--target/linux/oxnas/profiles/100-Generic.mk53
1 files changed, 53 insertions, 0 deletions
diff --git a/target/linux/oxnas/profiles/100-Generic.mk b/target/linux/oxnas/profiles/100-Generic.mk
new file mode 100644
index 0000000000..734b12376a
--- /dev/null
+++ b/target/linux/oxnas/profiles/100-Generic.mk
@@ -0,0 +1,53 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/POGOPLUG_PRO
+ NAME:=PogoPlug Pro
+ PACKAGES:= \
+ uboot-envtools kmod-usb2-oxnas
+endef
+
+define Profile/POGOPLUG_PRO/Description
+ Profile with built-in ox820 PogoPlug Pro device-tree
+ (board with miniPCIe slot)
+endef
+
+define Profile/POGOPLUG_V3
+ NAME:=PogoPlug V3
+ PACKAGES:= \
+ uboot-envtools kmod-usb2-oxnas
+endef
+
+define Profile/POGOPLUG_V3/Description
+ Profile with built-in ox820 PogoPlug V3 device-tree
+ (board without miniPCIe slot)
+endef
+
+define Profile/STG212
+ NAME:=MitraStar STG-212
+ PACKAGES:= \
+ uboot-envtools kmod-usb2-oxnas
+endef
+
+define Profile/STG212/Description
+ Profile with built-in ox820 STG-212 device-tree
+endef
+
+define Profile/KD20
+ NAME:=Shuttle KD20
+ PACKAGES:= \
+ uboot-envtools kmod-usb2-oxnas kmod-usb3 kmod-rtc-pcf8563
+endef
+
+define Profile/KD20/Description
+ Profile with built-in ox820 KD20 device-tree
+endef
+
+$(eval $(call Profile,POGOPLUG_PRO))
+$(eval $(call Profile,POGOPLUG_V3))
+$(eval $(call Profile,STG212))
+$(eval $(call Profile,KD20))