aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 2280a1a618..266df857a3 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -259,6 +259,20 @@ define Device/tl-wr841n-v13
endef
TARGET_DEVICES += tl-wr841n-v13
+define Device/tplink_tl-wr841n-v14
+ $(Device/tplink)
+ DTS := TL-WR841NV14
+ IMAGE_SIZE := 3968k
+ DEVICE_TITLE := TP-Link TL-WR841N v14
+ TPLINK_FLASHLAYOUT := 4Mmtk
+ TPLINK_HWID := 0x08410014
+ TPLINK_HWREV := 0x1
+ TPLINK_HWREVADD := 0x14
+ TPLINK_HVERSION := 3
+ IMAGE/tftp-recovery.bin := pad-extra 64k | $$(IMAGE/factory.bin)
+endef
+TARGET_DEVICES += tplink_tl-wr841n-v14
+
define Device/tplink_c20-v4
$(Device/tplink)
DTS := ArcherC20v4