aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/s3c24xx/patches-2.6.31/010-neo1973_mach.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/s3c24xx/patches-2.6.31/010-neo1973_mach.patch')
-rw-r--r--target/linux/s3c24xx/patches-2.6.31/010-neo1973_mach.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/target/linux/s3c24xx/patches-2.6.31/010-neo1973_mach.patch b/target/linux/s3c24xx/patches-2.6.31/010-neo1973_mach.patch
new file mode 100644
index 0000000000..8238275d0c
--- /dev/null
+++ b/target/linux/s3c24xx/patches-2.6.31/010-neo1973_mach.patch
@@ -0,0 +1,63 @@
+From 06344e2a663fa052c9ff0c508e8c978ce51d933b Mon Sep 17 00:00:00 2001
+From: Lars-Peter Clausen <lars@metafoo.de>
+Date: Tue, 21 Jul 2009 12:42:17 +0200
+Subject: [PATCH] 014-neo1973_mach.patch
+
+---
+ arch/arm/mach-s3c2442/Makefile | 6 ++++++
+ arch/arm/plat-s3c24xx/Kconfig | 16 ++++++++++++++++
+ drivers/misc/Makefile | 3 +++
+ 3 files changed, 25 insertions(+), 0 deletions(-)
+
+diff --git a/arch/arm/mach-s3c2442/Makefile b/arch/arm/mach-s3c2442/Makefile
+index 2a19113..1350103 100644
+--- a/arch/arm/mach-s3c2442/Makefile
++++ b/arch/arm/mach-s3c2442/Makefile
+@@ -16,3 +16,8 @@ obj-$(CONFIG_MACH_NEO1973_GTA02) += mach-gta02.o
+
+ # Machine support
+
++obj-$(CONFIG_MACH_NEO1973) += \
++ gta02-pm-gsm.o \
++ gta02-pm-gps.o \
++ gta02-pm-bt.o \
++ gta02-pm-wlan.o
+diff --git a/arch/arm/plat-s3c24xx/Kconfig b/arch/arm/plat-s3c24xx/Kconfig
+index 5b0bc91..ee2d47e 100644
+--- a/arch/arm/plat-s3c24xx/Kconfig
++++ b/arch/arm/plat-s3c24xx/Kconfig
+@@ -112,4 +112,20 @@ config MACH_SMDK
+ help
+ Common machine code for SMDK2410 and SMDK2440
+
++config MACH_NEO1973
++ bool
++ select RFKILL
++ select SERIAL_SAMSUNG
++ select SERIAL_SAMSUNG_CONSOLE
++ help
++ Common machine code for Neo1973 hardware
++
++config MACH_NEO1973
++ bool
++ select RFKILL
++ select SERIAL_SAMSUNG
++ select SERIAL_SAMSUNG_CONSOLE
++ help
++ Common machine code for Neo1973 hardware
++
+ endif
+diff --git a/drivers/misc/Makefile b/drivers/misc/Makefile
+index 36f733c..61888c7 100644
+--- a/drivers/misc/Makefile
++++ b/drivers/misc/Makefile
+@@ -22,3 +22,6 @@ obj-$(CONFIG_ISL29003) += isl29003.o
+ obj-$(CONFIG_C2PORT) += c2port/
+ obj-y += eeprom/
+ obj-y += cb710/
++obj-$(CONFIG_MACH_NEO1973) += gta02_pm_host.o \
++ gta02_pm_resume_reason.o
++
+--
+1.5.6.5
+