aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/s3c24xx/patches-2.6.31/058-lis302dl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/s3c24xx/patches-2.6.31/058-lis302dl.patch')
-rw-r--r--target/linux/s3c24xx/patches-2.6.31/058-lis302dl.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/target/linux/s3c24xx/patches-2.6.31/058-lis302dl.patch b/target/linux/s3c24xx/patches-2.6.31/058-lis302dl.patch
new file mode 100644
index 0000000000..3670ea4b49
--- /dev/null
+++ b/target/linux/s3c24xx/patches-2.6.31/058-lis302dl.patch
@@ -0,0 +1,45 @@
+From 3c9a0b287a1ca66e24e041c87047bb559b855ef8 Mon Sep 17 00:00:00 2001
+From: Lars-Peter Clausen <lars@metafoo.de>
+Date: Tue, 21 Jul 2009 12:47:58 +0200
+Subject: [PATCH] 057-lis302dl.patch
+
+---
+ drivers/input/misc/Kconfig | 9 +++++++++
+ drivers/input/misc/Makefile | 2 ++
+ 2 files changed, 11 insertions(+), 0 deletions(-)
+
+diff --git a/drivers/input/misc/Kconfig b/drivers/input/misc/Kconfig
+index 1acfa3a..4af8eb4 100644
+--- a/drivers/input/misc/Kconfig
++++ b/drivers/input/misc/Kconfig
+@@ -230,6 +230,15 @@ config HP_SDC_RTC
+ Say Y here if you want to support the built-in real time clock
+ of the HP SDC controller.
+
++config INPUT_LIS302DL
++ tristate "STmicro LIS302DL 3-axis accelerometer"
++ depends on SPI_MASTER
++ help
++ SPI driver for the STmicro LIS302DL 3-axis accelerometer.
++
++ The userspece interface is a 3-axis (X/Y/Z) relative movement
++ Linux input device, reporting REL_[XYZ] events.
++
+ config INPUT_PCF50633_PMU
+ tristate "PCF50633 PMU events"
+ depends on MFD_PCF50633
+diff --git a/drivers/input/misc/Makefile b/drivers/input/misc/Makefile
+index 0d979fd..c959f35 100644
+--- a/drivers/input/misc/Makefile
++++ b/drivers/input/misc/Makefile
+@@ -14,6 +14,7 @@ obj-$(CONFIG_INPUT_TWL4030_PWRBUTTON) += twl4030-pwrbutton.o
+ obj-$(CONFIG_HP_SDC_RTC) += hp_sdc_rtc.o
+ obj-$(CONFIG_INPUT_IXP4XX_BEEPER) += ixp4xx-beeper.o
+ obj-$(CONFIG_INPUT_KEYSPAN_REMOTE) += keyspan_remote.o
++obj-$(CONFIG_INPUT_LIS302DL) += lis302dl.o
+ obj-$(CONFIG_INPUT_M68K_BEEP) += m68kspkr.o
+ obj-$(CONFIG_INPUT_PCF50633_PMU) += pcf50633-input.o
+ obj-$(CONFIG_INPUT_PCSPKR) += pcspkr.o
+--
+1.5.6.5
+