aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/sunxi/image')
-rw-r--r--target/linux/sunxi/image/cortexa53.mk17
1 files changed, 15 insertions, 2 deletions
diff --git a/target/linux/sunxi/image/cortexa53.mk b/target/linux/sunxi/image/cortexa53.mk
index fe561d0923..2d18b0b227 100644
--- a/target/linux/sunxi/image/cortexa53.mk
+++ b/target/linux/sunxi/image/cortexa53.mk
@@ -9,13 +9,18 @@ define Device/sun50i
KERNEL := kernel-bin
endef
+define Device/sun50i-a64
+ SOC := sun50i-a64
+ $(Device/sun50i)
+endef
+
define Device/sun50i-h5
SOC := sun50i-h5
$(Device/sun50i)
endef
-define Device/sun50i-a64
- SOC := sun50i-a64
+define Device/sun50i-h6
+ SOC := sun50i-h6
$(Device/sun50i)
endef
@@ -79,6 +84,14 @@ define Device/pine64_sopine-baseboard
endef
TARGET_DEVICES += pine64_sopine-baseboard
+define Device/xunlong_orangepi-one-plus
+ $(Device/sun50i-h6)
+ DEVICE_VENDOR := Xunlong
+ DEVICE_MODEL := Orange Pi One Plus
+ SUNXI_DTS_DIR := allwinner/
+endef
+TARGET_DEVICES += xunlong_orangepi-one-plus
+
define Device/xunlong_orangepi-pc2
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi PC 2