aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/patches-5.10/011-tune_lzma_options.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86/patches-5.10/011-tune_lzma_options.patch')
-rw-r--r--target/linux/x86/patches-5.10/011-tune_lzma_options.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/x86/patches-5.10/011-tune_lzma_options.patch b/target/linux/x86/patches-5.10/011-tune_lzma_options.patch
new file mode 100644
index 0000000000..c19e1f54db
--- /dev/null
+++ b/target/linux/x86/patches-5.10/011-tune_lzma_options.patch
@@ -0,0 +1,22 @@
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -370,7 +370,7 @@ quiet_cmd_bzip2 = BZIP2 $@
+ # ---------------------------------------------------------------------------
+
+ quiet_cmd_lzma = LZMA $@
+- cmd_lzma = { cat $(real-prereqs) | $(LZMA) e -d20 -lc1 -lp2 -pb2 -eos -si -so; $(size_append); } > $@
++ cmd_lzma = { cat $(real-prereqs) | $(LZMA) e -lc8 -eos -si -so; $(size_append); } > $@
+
+ quiet_cmd_lzo = LZO $@
+ cmd_lzo = { cat $(real-prereqs) | $(KLZOP) -9; $(size_append); } > $@
+--- a/arch/x86/include/asm/boot.h
++++ b/arch/x86/include/asm/boot.h
+@@ -24,7 +24,7 @@
+ # error "Invalid value for CONFIG_PHYSICAL_ALIGN"
+ #endif
+
+-#if defined(CONFIG_KERNEL_BZIP2)
++#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
+ # define BOOT_HEAP_SIZE 0x400000
+ #elif defined(CONFIG_KERNEL_ZSTD)
+ /*