aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/zynq/patches-4.14
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/zynq/patches-4.14')
-rw-r--r--target/linux/zynq/patches-4.14/020-v4.17-add-digilent-zybo-z7-board.patch94
-rw-r--r--target/linux/zynq/patches-4.14/022-v4.19-dts-set-correct-manufacturer-for-ZedBoard-and-MicroZed.patch38
-rw-r--r--target/linux/zynq/patches-4.14/025-v4.19-update-digilent-zybo-z7-dts.patch52
3 files changed, 0 insertions, 184 deletions
diff --git a/target/linux/zynq/patches-4.14/020-v4.17-add-digilent-zybo-z7-board.patch b/target/linux/zynq/patches-4.14/020-v4.17-add-digilent-zybo-z7-board.patch
deleted file mode 100644
index 7ff31e374f..0000000000
--- a/target/linux/zynq/patches-4.14/020-v4.17-add-digilent-zybo-z7-board.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-From ba5c7a032c2ae66d5467820daab898e5f9048405 Mon Sep 17 00:00:00 2001
-From: Nobuhiro Iwamatsu <nobuhiro.iwamatsu@cybertrust.co.jp>
-Date: Wed, 28 Feb 2018 11:25:52 +0900
-Subject: [PATCH] arm: dts: zynq: Add Digilent Zybo Z7 board
-
-This add a DTS for the Digilent Zybo Z7 board.
-This board is the successor board of Zybo, these are almost the same except
-for ps-clk-frequency specifications.
-
-Signed-off-by: Nobuhiro Iwamatsu <nobuhiro.iwamatsu@cybertrust.co.jp>
-Reviewed-by: Rob Herring <robh@kernel.org>
-Signed-off-by: Michal Simek <michal.simek@xilinx.com>
----
-Modifications:
-- Removed changes to file Documentation/devicetree/bindings/arm/xilinx.txt
----
- arch/arm/boot/dts/Makefile | 3 +-
- arch/arm/boot/dts/zynq-zybo-z7.dts | 58 +++++++++++++++++++
- 2 files changed, 60 insertions(+), 1 deletion(-)
- create mode 100644 arch/arm/boot/dts/zynq-zybo-z7.dts
-
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -1006,7 +1006,8 @@ dtb-$(CONFIG_ARCH_ZYNQ) += \
- zynq-zc702.dtb \
- zynq-zc706.dtb \
- zynq-zed.dtb \
-- zynq-zybo.dtb
-+ zynq-zybo.dtb \
-+ zynq-zybo-z7.dtb
- dtb-$(CONFIG_MACH_ARMADA_370) += \
- armada-370-db.dtb \
- armada-370-dlink-dns327l.dtb \
---- /dev/null
-+++ b/arch/arm/boot/dts/zynq-zybo-z7.dts
-@@ -0,0 +1,58 @@
-+// SPDX-License-Identifier: GPL-2.0+
-+/dts-v1/;
-+#include "zynq-7000.dtsi"
-+
-+/ {
-+ model = "Zynq ZYBO Z7 Development Board";
-+ compatible = "digilent,zynq-zybo-z7", "xlnx,zynq-7000";
-+
-+ aliases {
-+ ethernet0 = &gem0;
-+ serial0 = &uart1;
-+ };
-+
-+ memory@0 {
-+ device_type = "memory";
-+ reg = <0x0 0x20000000>;
-+ };
-+
-+ chosen {
-+ bootargs = "";
-+ stdout-path = "serial0:115200n8";
-+ };
-+
-+ usb_phy0: phy0 {
-+ #phy-cells = <0>;
-+ compatible = "usb-nop-xceiv";
-+ reset-gpios = <&gpio0 46 1>;
-+ };
-+};
-+
-+&clkc {
-+ ps-clk-frequency = <33333333>;
-+};
-+
-+&gem0 {
-+ status = "okay";
-+ phy-mode = "rgmii-id";
-+ phy-handle = <&ethernet_phy>;
-+
-+ ethernet_phy: ethernet-phy@0 {
-+ reg = <0>;
-+ device_type = "ethernet-phy";
-+ };
-+};
-+
-+&sdhci0 {
-+ status = "okay";
-+};
-+
-+&uart1 {
-+ status = "okay";
-+};
-+
-+&usb0 {
-+ status = "okay";
-+ dr_mode = "host";
-+ usb-phy = <&usb_phy0>;
-+};
diff --git a/target/linux/zynq/patches-4.14/022-v4.19-dts-set-correct-manufacturer-for-ZedBoard-and-MicroZed.patch b/target/linux/zynq/patches-4.14/022-v4.19-dts-set-correct-manufacturer-for-ZedBoard-and-MicroZed.patch
deleted file mode 100644
index 3091846a63..0000000000
--- a/target/linux/zynq/patches-4.14/022-v4.19-dts-set-correct-manufacturer-for-ZedBoard-and-MicroZed.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From ef4c422d167afcd15c8bae1f841ef59334c1f973 Mon Sep 17 00:00:00 2001
-From: Luis Araneda <luaraneda@gmail.com>
-Date: Thu, 12 Jul 2018 00:10:19 -0400
-Subject: [PATCH] ARM: dts: zynq: Set correct manufacturer for ZedBoard and
- MicroZed boards
-
-Both boards are made by Avnet, Inc. So add an additional
-value to the compatible property
-
-Signed-off-by: Luis Araneda <luaraneda@gmail.com>
-Signed-off-by: Michal Simek <michal.simek@xilinx.com>
----
- arch/arm/boot/dts/zynq-microzed.dts | 2 +-
- arch/arm/boot/dts/zynq-zed.dts | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
---- a/arch/arm/boot/dts/zynq-microzed.dts
-+++ b/arch/arm/boot/dts/zynq-microzed.dts
-@@ -16,7 +16,7 @@
-
- / {
- model = "Zynq MicroZED Development Board";
-- compatible = "xlnx,zynq-microzed", "xlnx,zynq-7000";
-+ compatible = "avnet,zynq-microzed", "xlnx,zynq-microzed", "xlnx,zynq-7000";
-
- aliases {
- ethernet0 = &gem0;
---- a/arch/arm/boot/dts/zynq-zed.dts
-+++ b/arch/arm/boot/dts/zynq-zed.dts
-@@ -16,7 +16,7 @@
-
- / {
- model = "Zynq Zed Development Board";
-- compatible = "xlnx,zynq-zed", "xlnx,zynq-7000";
-+ compatible = "avnet,zynq-zed", "xlnx,zynq-zed", "xlnx,zynq-7000";
-
- aliases {
- ethernet0 = &gem0;
diff --git a/target/linux/zynq/patches-4.14/025-v4.19-update-digilent-zybo-z7-dts.patch b/target/linux/zynq/patches-4.14/025-v4.19-update-digilent-zybo-z7-dts.patch
deleted file mode 100644
index d4726498d2..0000000000
--- a/target/linux/zynq/patches-4.14/025-v4.19-update-digilent-zybo-z7-dts.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 7d90ca6f19199a54d3f8417c5f36c50dfa0accc8 Mon Sep 17 00:00:00 2001
-From: Luis Araneda <luaraneda@gmail.com>
-Date: Thu, 12 Jul 2018 01:50:46 -0400
-Subject: [PATCH] v4.19: Backport dts updates to the Digilent Zybo Z7 board
-
-- 7d90ca6: Fix memory size (512 MiB -> 1 GiB)
-- edd62b9: Use GPIO constants
-- a2b7baf: Add gpio-leds node
-
-Signed-off-by: Luis Araneda <luaraneda@gmail.com>
----
-
---- a/arch/arm/boot/dts/zynq-zybo-z7.dts
-+++ b/arch/arm/boot/dts/zynq-zybo-z7.dts
-@@ -1,6 +1,7 @@
- // SPDX-License-Identifier: GPL-2.0+
- /dts-v1/;
- #include "zynq-7000.dtsi"
-+#include <dt-bindings/gpio/gpio.h>
-
- / {
- model = "Zynq ZYBO Z7 Development Board";
-@@ -13,7 +14,7 @@
-
- memory@0 {
- device_type = "memory";
-- reg = <0x0 0x20000000>;
-+ reg = <0x0 0x40000000>;
- };
-
- chosen {
-@@ -21,10 +22,19 @@
- stdout-path = "serial0:115200n8";
- };
-
-+ gpio-leds {
-+ compatible = "gpio-leds";
-+
-+ ld4 {
-+ label = "zynq-zybo-z7:green:ld4";
-+ gpios = <&gpio0 7 GPIO_ACTIVE_HIGH>;
-+ };
-+ };
-+
- usb_phy0: phy0 {
- #phy-cells = <0>;
- compatible = "usb-nop-xceiv";
-- reset-gpios = <&gpio0 46 1>;
-+ reset-gpios = <&gpio0 46 GPIO_ACTIVE_LOW>;
- };
- };
-