aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/layerscape/base-files/lib/upgrade/platform.sh5
-rw-r--r--target/linux/layerscape/image/armv8_64b.mk41
2 files changed, 46 insertions, 0 deletions
diff --git a/target/linux/layerscape/base-files/lib/upgrade/platform.sh b/target/linux/layerscape/base-files/lib/upgrade/platform.sh
index a8d83de7ea..f9b1e57a43 100644
--- a/target/linux/layerscape/base-files/lib/upgrade/platform.sh
+++ b/target/linux/layerscape/base-files/lib/upgrade/platform.sh
@@ -72,6 +72,7 @@ platform_copy_config() {
fsl,ls1021a-iot-sdboot | \
fsl,ls1021a-twr-sdboot | \
fsl,ls1043a-rdb-sdboot | \
+ fsl,ls1046a-frwy-sdboot | \
fsl,ls1046a-rdb-sdboot | \
fsl,ls1088a-rdb-sdboot)
platform_copy_config_sdboot
@@ -95,6 +96,8 @@ platform_check_image() {
fsl,ls1021a-twr-sdboot | \
fsl,ls1043a-rdb | \
fsl,ls1043a-rdb-sdboot | \
+ fsl,ls1046a-frwy | \
+ fsl,ls1046a-frwy-sdboot | \
fsl,ls1046a-rdb | \
fsl,ls1046a-rdb-sdboot | \
fsl,ls1088a-rdb | \
@@ -125,6 +128,7 @@ platform_do_upgrade() {
fsl,ls1012a-rdb | \
fsl,ls1021a-twr | \
fsl,ls1043a-rdb | \
+ fsl,ls1046a-frwy | \
fsl,ls1046a-rdb | \
fsl,ls1088a-rdb | \
fsl,ls2088a-rdb)
@@ -135,6 +139,7 @@ platform_do_upgrade() {
fsl,ls1021a-iot-sdboot | \
fsl,ls1021a-twr-sdboot | \
fsl,ls1043a-rdb-sdboot | \
+ fsl,ls1046a-frwy-sdboot | \
fsl,ls1046a-rdb-sdboot | \
fsl,ls1088a-rdb-sdboot)
platform_do_upgrade_sdboot "$1"
diff --git a/target/linux/layerscape/image/armv8_64b.mk b/target/linux/layerscape/image/armv8_64b.mk
index 958faa270e..c037061aa2 100644
--- a/target/linux/layerscape/image/armv8_64b.mk
+++ b/target/linux/layerscape/image/armv8_64b.mk
@@ -151,6 +151,47 @@ define Device/fsl_ls1043a-rdb-sdboot
endef
TARGET_DEVICES += fsl_ls1043a-rdb-sdboot
+define Device/fsl_ls1046a-frwy
+ DEVICE_VENDOR := NXP
+ DEVICE_MODEL := FRWY-LS1046A
+ DEVICE_VARIANT := Default
+ DEVICE_PACKAGES += \
+ layerscape-fman \
+ tfa-ls1046a-frwy
+ DEVICE_DTS := freescale/fsl-ls1046a-frwy-sdk
+ IMAGE/firmware.bin := \
+ ls-clean | \
+ ls-append $(1)-bl2.pbl | pad-to 1M | \
+ ls-append $(1)-fip.bin | pad-to 5M | \
+ ls-append $(1)-uboot-env.bin | pad-to 9M | \
+ ls-append fsl_ls1046a-rdb-fman.bin | pad-to 15M | \
+ ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
+ append-kernel | pad-to 32M | \
+ append-rootfs | pad-rootfs | check-size
+endef
+TARGET_DEVICES += fsl_ls1046a-frwy
+
+define Device/fsl_ls1046a-frwy-sdboot
+ $(Device/fsl-sdboot)
+ DEVICE_VENDOR := NXP
+ DEVICE_MODEL := FRWY-LS1046A
+ DEVICE_VARIANT := SD Card Boot
+ DEVICE_PACKAGES += \
+ layerscape-fman \
+ tfa-ls1046a-frwy-sdboot
+ DEVICE_DTS := freescale/fsl-ls1046a-frwy-sdk
+ IMAGE/sdcard.img.gz := \
+ ls-clean | \
+ ls-append-sdhead $(1) | pad-to 4K | \
+ ls-append $(1)-bl2.pbl | pad-to 1M | \
+ ls-append $(1)-fip.bin | pad-to 5M | \
+ ls-append $(1)-uboot-env.bin | pad-to 9M | \
+ ls-append fsl_ls1046a-rdb-fman.bin | pad-to 16M | \
+ ls-append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
+ append-rootfs | pad-to $(LS_SD_IMAGE_SIZE)M | gzip
+endef
+TARGET_DEVICES += fsl_ls1046a-frwy-sdboot
+
define Device/fsl_ls1046a-rdb
$(Device/fix-sysupgrade)
DEVICE_VENDOR := NXP