aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/layerscape/image/armv8_32b.mk38
-rw-r--r--target/linux/layerscape/image/armv8_64b.mk36
2 files changed, 39 insertions, 35 deletions
diff --git a/target/linux/layerscape/image/armv8_32b.mk b/target/linux/layerscape/image/armv8_32b.mk
index b3beefba39..95418926fd 100644
--- a/target/linux/layerscape/image/armv8_32b.mk
+++ b/target/linux/layerscape/image/armv8_32b.mk
@@ -41,31 +41,33 @@ define Device/ls1012ardb
endef
TARGET_DEVICES += ls1012ardb
-define Device/ls1012afrdm
- DEVICE_TITLE := LS1012AFRDM
+define Device/ls1012afrwy
+ DEVICE_TITLE := LS1012AFRWY
DEVICE_PACKAGES += \
- layerscape-rcw-ls1012afrdm \
+ layerscape-rcw-ls1012afrwy \
layerscape-ppfe \
- layerscape-ppa-ls1012afrdm \
- u-boot-ls1012afrdm-image \
+ layerscape-ppa-ls1012afrwy \
+ u-boot-ls1012afrwy-image \
kmod-ppfe
- DEVICE_DTS := ../../../arm64/boot/dts/freescale/fsl-ls1012a-frdm
- UBIFS_OPTS := -m 1 -e 262016 -c 128
- UBINIZE_OPTS := -E 5
- BLOCKSIZE := 256KiB
- PAGESIZE := 1
+ DEVICE_DTS := ../../../arm64/boot/dts/freescale/fsl-ls1012a-frwy
+ FILESYSTEMS := ext4
+ IMAGES := firmware.bin sdcard.img
IMAGE/firmware.bin := \
ls-clean | \
- ls-append $(1)-rcw.bin | pad-to 1M | \
- ls-append $(1)-uboot.bin | pad-to 3M | \
- ls-append $(1)-uboot-env.bin | pad-to 4M | \
- ls-append $(1)-ppa.itb | pad-to 10M | \
- ls-append pfe.itb | pad-to 15M | \
+ ls-append $(1)-rcw.bin | pad-to 128K | \
+ ls-append pfe.itb | pad-to 384K | \
+ ls-append $(1)-ppa.itb | pad-to 1024K | \
+ ls-append $(1)-uboot.bin | pad-to 1856K | \
+ ls-append $(1)-uboot-env.bin | pad-to 2048K | \
+ check-size 2097153
+ IMAGE/sdcard.img := \
+ ls-clean | \
+ ls-append-sdhead $(1) | pad-to 15M | \
ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
- append-kernel | pad-to 32M | \
- append-ubi | check-size 67108865
+ append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
+ append-rootfs | check-size $(LS_SD_IMAGE_SIZE)
endef
-TARGET_DEVICES += ls1012afrdm
+TARGET_DEVICES += ls1012afrwy
define Device/ls1043ardb
DEVICE_TITLE := LS1043ARDB
diff --git a/target/linux/layerscape/image/armv8_64b.mk b/target/linux/layerscape/image/armv8_64b.mk
index a144fd0c66..79e05efc1c 100644
--- a/target/linux/layerscape/image/armv8_64b.mk
+++ b/target/linux/layerscape/image/armv8_64b.mk
@@ -39,30 +39,32 @@ define Device/ls1012ardb
endef
TARGET_DEVICES += ls1012ardb
-define Device/ls1012afrdm
- DEVICE_TITLE := LS1012AFRDM
+define Device/ls1012afrwy
+ DEVICE_TITLE := LS1012AFRWY
DEVICE_PACKAGES += \
- layerscape-rcw-ls1012afrdm \
+ layerscape-rcw-ls1012afrwy \
layerscape-ppfe \
- layerscape-ppa-ls1012afrdm \
+ layerscape-ppa-ls1012afrwy \
kmod-ppfe
- DEVICE_DTS := freescale/fsl-ls1012a-frdm
- UBIFS_OPTS := -m 1 -e 262016 -c 128
- UBINIZE_OPTS := -E 5
- BLOCKSIZE := 256KiB
- PAGESIZE := 1
+ DEVICE_DTS := freescale/fsl-ls1012a-frwy
+ FILESYSTEMS := ext4
+ IMAGES := firmware.bin sdcard.img
IMAGE/firmware.bin := \
ls-clean | \
- ls-append $(1)-rcw.bin | pad-to 1M | \
- ls-append $(1)-uboot.bin | pad-to 3M | \
- ls-append $(1)-uboot-env.bin | pad-to 4M | \
- ls-append $(1)-ppa.itb | pad-to 10M | \
- ls-append pfe.itb | pad-to 15M | \
+ ls-append $(1)-rcw.bin | pad-to 128K | \
+ ls-append pfe.itb | pad-to 384K | \
+ ls-append $(1)-ppa.itb | pad-to 1024K | \
+ ls-append $(1)-uboot.bin | pad-to 1856K | \
+ ls-append $(1)-uboot-env.bin | pad-to 2048K | \
+ check-size 2097153
+ IMAGE/sdcard.img := \
+ ls-clean | \
+ ls-append-sdhead $(1) | pad-to 15M | \
ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
- append-kernel | pad-to 32M | \
- append-ubi | check-size 67108865
+ append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
+ append-rootfs | check-size $(LS_SD_IMAGE_SIZE)
endef
-TARGET_DEVICES += ls1012afrdm
+TARGET_DEVICES += ls1012afrwy
define Device/ls1043ardb
DEVICE_TITLE := LS1043ARDB