aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ath79/dts/ar9341_openmesh_om2p-hs-v3.dts8
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/01_leds1
-rw-r--r--target/linux/ath79/generic/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ath79/image/generic.mk9
4 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/ar9341_openmesh_om2p-hs-v3.dts b/target/linux/ath79/dts/ar9341_openmesh_om2p-hs-v3.dts
new file mode 100644
index 0000000000..e3b15b17f6
--- /dev/null
+++ b/target/linux/ath79/dts/ar9341_openmesh_om2p-hs-v3.dts
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9341_openmesh_om2p-hs.dtsi"
+
+/ {
+ compatible = "openmesh,om2p-hs-v3", "qca,ar9341";
+ model = "OpenMesh OM2P-HS v3";
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index 8926ffc0c8..3889969ee5 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -147,6 +147,7 @@ comfast,cf-e560ac)
comfast,cf-ew72|\
openmesh,om2p-hs-v1|\
openmesh,om2p-hs-v2|\
+openmesh,om2p-hs-v3|\
telco,t1)
ucidef_set_led_switch "lan" "LAN" "blue:lan" "switch0" "0x02"
ucidef_set_led_netdev "wan" "WAN" "blue:wan" "eth1"
diff --git a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
index 73c328173a..9ff36f1bf5 100644
--- a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
@@ -53,6 +53,7 @@ platform_do_upgrade() {
openmesh,om2p-v4|\
openmesh,om2p-hs-v1|\
openmesh,om2p-hs-v2|\
+ openmesh,om2p-hs-v3|\
openmesh,om2p-hs-v4)
PART_NAME="inactive"
platform_do_upgrade_openmesh "$1"
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 4e80ac8402..631cc2fd6a 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1595,6 +1595,15 @@ define Device/openmesh_om2p-hs-v2
endef
TARGET_DEVICES += openmesh_om2p-hs-v2
+define Device/openmesh_om2p-hs-v3
+ $(Device/openmesh_om2p-common)
+ SOC := ar9341
+ DEVICE_MODEL := OM2P-HS
+ DEVICE_VARIANT := v3
+ SUPPORTED_DEVICES += om2p-hsv3
+endef
+TARGET_DEVICES += openmesh_om2p-hs-v3
+
define Device/openmesh_om2p-hs-v4
$(Device/openmesh_om2p-common)
SOC := qca9533