aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ath79/dts/qca9533_tplink_tl-wr802n-v1.dts9
-rw-r--r--target/linux/ath79/dts/qca9533_tplink_tl-wr802n-v2.dts9
-rw-r--r--target/linux/ath79/dts/qca9533_tplink_tl-wr802n.dtsi99
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk24
-rwxr-xr-xtarget/linux/ath79/tiny/base-files/etc/board.d/02_network4
-rw-r--r--target/linux/ath79/tiny/base-files/etc/uci-defaults/04_led_migration18
6 files changed, 162 insertions, 1 deletions
diff --git a/target/linux/ath79/dts/qca9533_tplink_tl-wr802n-v1.dts b/target/linux/ath79/dts/qca9533_tplink_tl-wr802n-v1.dts
new file mode 100644
index 0000000000..229c5fa7bd
--- /dev/null
+++ b/target/linux/ath79/dts/qca9533_tplink_tl-wr802n-v1.dts
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9533_tplink_tl-wr802n.dtsi"
+
+/ {
+ model = "TP-Link TL-WR802N v1";
+ compatible = "tplink,tl-wr802n-v1", "qca,qca9533";
+};
diff --git a/target/linux/ath79/dts/qca9533_tplink_tl-wr802n-v2.dts b/target/linux/ath79/dts/qca9533_tplink_tl-wr802n-v2.dts
new file mode 100644
index 0000000000..cbfd275d2b
--- /dev/null
+++ b/target/linux/ath79/dts/qca9533_tplink_tl-wr802n-v2.dts
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9533_tplink_tl-wr802n.dtsi"
+
+/ {
+ model = "TP-Link TL-WR802N v2";
+ compatible = "tplink,tl-wr802n-v2", "qca,qca9533";
+};
diff --git a/target/linux/ath79/dts/qca9533_tplink_tl-wr802n.dtsi b/target/linux/ath79/dts/qca9533_tplink_tl-wr802n.dtsi
new file mode 100644
index 0000000000..f89d020672
--- /dev/null
+++ b/target/linux/ath79/dts/qca9533_tplink_tl-wr802n.dtsi
@@ -0,0 +1,99 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca953x.dtsi"
+
+/ {
+ chosen {
+ bootargs = "console=ttyS0,115200n8";
+ };
+
+ aliases {
+ led-boot = &led_system;
+ led-failsafe = &led_system;
+ led-running = &led_system;
+ led-upgrade = &led_system;
+ label-mac-device = &wmac;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_system: system {
+ label = "tp-link:green:system";
+ gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "Reset button";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&uart {
+ status = "okay";
+};
+
+&spi {
+ status = "okay";
+
+ num-cs = <1>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <50000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ uboot: partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x020000>;
+ read-only;
+ };
+
+ partition@20000 {
+ label = "firmware";
+ reg = <0x020000 0x3d0000>;
+ compatible = "tplink,firmware";
+ };
+
+ art: partition@3f0000 {
+ label = "art";
+ reg = <0x3f0000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&wmac {
+ status = "okay";
+
+ mtd-cal-data = <&art 0x1000>;
+ mtd-mac-address = <&uboot 0x1fc00>;
+};
+
+&eth0 {
+ status = "okay";
+
+ phy-handle = <&swphy4>;
+
+ mtd-mac-address = <&uboot 0x1fc00>;
+ mtd-mac-address-increment = <1>;
+};
+
+&eth1 {
+ compatible = "syscon", "simple-mfd";
+};
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index a5a76edd05..6e07d290f9 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -272,6 +272,30 @@ define Device/tplink_tl-wr743nd-v1
endef
TARGET_DEVICES += tplink_tl-wr743nd-v1
+define Device/tplink_tl-wr802n-v1
+ $(Device/tplink-4mlzma)
+ SOC := qca9533
+ DEVICE_MODEL := TL-WR802N
+ DEVICE_VARIANT := v1
+ TPLINK_HWID := 0x08020001
+ SUPPORTED_DEVICES += tl-wr802n-v1
+endef
+TARGET_DEVICES += tplink_tl-wr802n-v1
+
+define Device/tplink_tl-wr802n-v2
+ $(Device/tplink-4mlzma)
+ SOC := qca9533
+ DEVICE_MODEL := TL-WR802N
+ DEVICE_VARIANT := v2
+ TPLINK_HWID := 0x08020002
+ TPLINK_HWREV := 2
+ SUPPORTED_DEVICES += tl-wr802n-v2
+ IMAGES += factory-us.bin factory-eu.bin
+ IMAGE/factory-us.bin := tplink-v1-image factory -C US
+ IMAGE/factory-eu.bin := tplink-v1-image factory -C EU
+endef
+TARGET_DEVICES += tplink_tl-wr802n-v2
+
define Device/tplink_tl-wr841-v5
$(Device/tplink-4m)
SOC := ar7240
diff --git a/target/linux/ath79/tiny/base-files/etc/board.d/02_network b/target/linux/ath79/tiny/base-files/etc/board.d/02_network
index 5e559363b2..bff17bcce8 100755
--- a/target/linux/ath79/tiny/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/tiny/base-files/etc/board.d/02_network
@@ -43,7 +43,9 @@ ath79_setup_interfaces()
tplink,tl-wa901nd-v2|\
tplink,tl-wa901nd-v4|\
tplink,tl-wa901nd-v5|\
- tplink,tl-wr703n)
+ tplink,tl-wr703n|\
+ tplink,tl-wr802n-v1|\
+ tplink,tl-wr802n-v2)
ucidef_set_interface_lan "eth0"
;;
tplink,tl-mr3220-v1|\
diff --git a/target/linux/ath79/tiny/base-files/etc/uci-defaults/04_led_migration b/target/linux/ath79/tiny/base-files/etc/uci-defaults/04_led_migration
new file mode 100644
index 0000000000..377135f530
--- /dev/null
+++ b/target/linux/ath79/tiny/base-files/etc/uci-defaults/04_led_migration
@@ -0,0 +1,18 @@
+. /lib/functions.sh
+. /lib/functions/migrations.sh
+
+board=$(board_name)
+boardonly="${board##*,}"
+
+case "$board" in
+tplink,tl-wr802n-v1)
+ migrate_leds ":blue:=:green:"
+ ;;
+tplink,tl-wr802n-v2)
+ migrate_leds "^$boardonly:=tp-link:"
+ ;;
+esac
+
+migrations_apply system
+
+exit 0