aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh2
-rw-r--r--target/linux/ar71xx/image/mikrotik.mk5
-rw-r--r--target/linux/ar71xx/mikrotik/config-default2
3 files changed, 5 insertions, 4 deletions
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 9cf20499e3..e0ba5d37ff 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -607,6 +607,8 @@ platform_pre_upgrade() {
local board=$(ar71xx_board_name)
case "$board" in
+ rb-941-2nd)
+ ;;
rb*|\
c-60|\
nbg6716|\
diff --git a/target/linux/ar71xx/image/mikrotik.mk b/target/linux/ar71xx/image/mikrotik.mk
index ff14f90ca6..7a3a9ceed8 100644
--- a/target/linux/ar71xx/image/mikrotik.mk
+++ b/target/linux/ar71xx/image/mikrotik.mk
@@ -22,7 +22,6 @@ endef
TARGET_DEVICES += nand-64m nand-large
define Device/rb-nor-flash-16M
- DEVICE_PROFILE := Default
BLOCKSIZE := 64k
IMAGE_SIZE := 16000k
LOADER_TYPE := elf
@@ -35,7 +34,9 @@ endef
define Device/rb-941-2nd
$(Device/rb-nor-flash-16M)
+ DEVICE_TITLE := hAP lite
+ DEVICE_PACKAGES:= rbcfg
BOARDNAME:= rb-941-2nd
endef
-TARGET_DEVICES += rb-941-2nd
+TARGET_DEVICES += rb-nor-flash-16M rb-941-2nd
diff --git a/target/linux/ar71xx/mikrotik/config-default b/target/linux/ar71xx/mikrotik/config-default
index 5fc98779ad..44ea327fb1 100644
--- a/target/linux/ar71xx/mikrotik/config-default
+++ b/target/linux/ar71xx/mikrotik/config-default
@@ -197,7 +197,6 @@ CONFIG_CRC16=y
CONFIG_CRYPTO_DEFLATE=y
CONFIG_GPIO_74X164=y
CONFIG_GPIO_LATCH=y
-# CONFIG_JFFS2_FS is not set
CONFIG_LEDS_RB750=y
CONFIG_LZO_DECOMPRESS=y
# CONFIG_MTD_CFI is not set
@@ -213,7 +212,6 @@ CONFIG_MTD_NAND_RB4XX=y
CONFIG_MTD_NAND_RB750=y
CONFIG_MTD_NAND_RB91X=y
# CONFIG_MTD_REDBOOT_PARTS is not set
-CONFIG_MTD_SPI_NOR_USE_4K_SECTORS=y
# CONFIG_MTD_TPLINK_PARTS is not set
CONFIG_MTD_UBI=y
CONFIG_MTD_UBI_BEB_LIMIT=20