aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/imx6/profiles/100-generic.mk2
-rw-r--r--target/linux/imx6/profiles/110-wandboard.mk2
-rw-r--r--target/linux/imx6/profiles/120-gateworks.mk2
-rw-r--r--target/linux/mxs/modules.mk18
4 files changed, 4 insertions, 20 deletions
diff --git a/target/linux/imx6/profiles/100-generic.mk b/target/linux/imx6/profiles/100-generic.mk
index 91ca3696ad..ec9ebc1fb4 100644
--- a/target/linux/imx6/profiles/100-generic.mk
+++ b/target/linux/imx6/profiles/100-generic.mk
@@ -8,7 +8,7 @@
define Profile/Generic
NAME:=Generic (default)
PACKAGES:= \
- kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy \
+ kmod-thermal-imx kmod-usb-chipidea-imx kmod-usb-mxs-phy \
uboot-envtools
endef
diff --git a/target/linux/imx6/profiles/110-wandboard.mk b/target/linux/imx6/profiles/110-wandboard.mk
index 4fa49ec6a6..2b5510fafe 100644
--- a/target/linux/imx6/profiles/110-wandboard.mk
+++ b/target/linux/imx6/profiles/110-wandboard.mk
@@ -8,7 +8,7 @@
define Profile/IMX6DL_WANDBOARD
NAME:=Wandboard Dual
PACKAGES:= \
- kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy \
+ kmod-thermal-imx kmod-usb-chipidea-imx kmod-usb-mxs-phy \
uboot-envtools
endef
diff --git a/target/linux/imx6/profiles/120-gateworks.mk b/target/linux/imx6/profiles/120-gateworks.mk
index 524e0c4573..115021af9c 100644
--- a/target/linux/imx6/profiles/120-gateworks.mk
+++ b/target/linux/imx6/profiles/120-gateworks.mk
@@ -8,7 +8,7 @@
define Profile/VENTANA
NAME:=Gateworks Ventana family
PACKAGES:= \
- kmod-thermal-imx kmod-sky2 kmod-usb-chipidea kmod-usb-mxs-phy \
+ kmod-thermal-imx kmod-sky2 kmod-usb-chipidea-imx kmod-usb-mxs-phy \
kmod-sound-core kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
kmod-can kmod-can-flexcan kmod-can-raw \
kmod-rtc-ds1672 kmod-gpio-pca953x kmod-hwmon-gsc kmod-eeprom-at24 \
diff --git a/target/linux/mxs/modules.mk b/target/linux/mxs/modules.mk
index 3f9c8f8334..10ea3d685f 100644
--- a/target/linux/mxs/modules.mk
+++ b/target/linux/mxs/modules.mk
@@ -33,22 +33,6 @@ endef
$(eval $(call KernelPackage,wdt-stmp3xxx))
-define KernelPackage/usb-chipidea-imx
- TITLE:=Support for ChipIdea controllers on Freescale i.MX SoCs
- DEPENDS:=+kmod-usb-chipidea @TARGET_mxs
- FILES:= \
- $(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc_imx.ko \
- $(LINUX_DIR)/drivers/usb/chipidea/usbmisc_imx.ko
- AUTOLOAD:=$(call AutoLoad,52,usbmisc_imx ci_hdrc_imx,1)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-chipidea-imx/description
- Kernel support for USB ChipIdea controllers on Freescale i.MX SoCs
-endef
-
-$(eval $(call KernelPackage,usb-chipidea-imx,1))
-
define KernelPackage/sound-soc-mxs
TITLE:=Freescale i.MX23/i.MX28 built-in SoC sound support
KCONFIG:= \
@@ -63,7 +47,7 @@ define KernelPackage/sound-soc-mxs
DEPENDS:=@TARGET_mxs +kmod-sound-soc-core
$(call AddDepends/sound)
endef
-
+
define KernelPackage/sound-soc-mxs/description
Kernel support for Freescale i.MX23/i.MX28 built-in SoC audio
endef