summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 2579933..01caa72 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,16 @@
D=indi-celestronaux
-default: ${D}/Makefile
- (cd ${D} && make)
- (cd ${D} && make install)
+default: indi-celestronaux/make indi-lxd650/make
-indi_celestron_aux/Makefile:
- (cd ${D} && cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr)
+install: indi-celestronaux/install indi-lxd650/install
+
+%/install:%/make
+ (cd ${@:%/install=%} && install)
+
+%/make:%/Makefile
+ (cd ${@:%/make=%} && make)
+
+
+%/Makefile:
+ (cd ${@:%/Makefile=%} && cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr)