summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile24
1 files changed, 14 insertions, 10 deletions
diff --git a/Makefile b/Makefile
index ac9f08d..6451b49 100644
--- a/Makefile
+++ b/Makefile
@@ -1,16 +1,20 @@
-D=indi-celestronaux
+D=indi-celestronaux indi-lxd650
-default: indi-celestronaux/make indi-lxd650/make
+default: ${D:%=%/default}
+clean: ${D:%=%/clean}
+install: ${D:%=%/install}
-install: indi-celestronaux/install indi-lxd650/install
+%/install:%/default
+ (cd ${@:%/install=%/build} && make install)
-%/install:%/make
- (cd ${@:%/install=%} && make install)
+%/default:%/build/Makefile
+ (cd ${@:%/default=%/build} && make)
-%/make:%/Makefile
- (cd ${@:%/make=%} && make)
+%/build/Makefile:
+ mkdir -p ${@:%/Makefile=%}
+ (cd ${@:%/Makefile=%} && cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr ..)
-
-%/Makefile:
- (cd ${@:%/Makefile=%} && cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr)
+%/clean:
+ /bin/rm -rf ${@:%/clean=%/build}
+