summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames McKenzie <root@ka-ata-killa.panaceas.james.local>2024-04-07 15:52:25 +0100
committerJames McKenzie <root@ka-ata-killa.panaceas.james.local>2024-04-07 15:52:25 +0100
commit167e5afe663660f1dad06368b25dde947efc0136 (patch)
tree9bc607ef7b9eae1783b2889387bbb786e47434c1
parent9d4e0ff9cacc0d8fe9566b8959e4ccee3f5ce8b4 (diff)
downloadSensor-Watch-pq-167e5afe663660f1dad06368b25dde947efc0136.tar.gz
Sensor-Watch-pq-167e5afe663660f1dad06368b25dde947efc0136.tar.bz2
Sensor-Watch-pq-167e5afe663660f1dad06368b25dde947efc0136.zip
add a couple more faces to alt_jmm
-rw-r--r--main/jmm.patch12
1 files changed, 7 insertions, 5 deletions
diff --git a/main/jmm.patch b/main/jmm.patch
index 0bde666..6cf4c0f 100644
--- a/main/jmm.patch
+++ b/main/jmm.patch
@@ -1,9 +1,9 @@
diff --git a/movement/alt_fw/jmm.h b/movement/alt_fw/jmm.h
new file mode 100644
-index 0000000..878b4a4
+index 0000000..e184f54
--- /dev/null
+++ b/movement/alt_fw/jmm.h
-@@ -0,0 +1,28 @@
+@@ -0,0 +1,30 @@
+#ifndef MOVEMENT_CONFIG_H_
+#define MOVEMENT_CONFIG_H_
+
@@ -19,6 +19,8 @@ index 0000000..878b4a4
+ totp_face_lfs,
+ moon_phase_face,
+ sunrise_sunset_face,
++ day_night_percentage_face,
++ tuning_tones_face,
+ decimal_time_face,
+ beats_face,
+ astronomy_face,
@@ -33,7 +35,7 @@ index 0000000..878b4a4
+
+#endif // MOVEMENT_CONFIG_H_
diff --git a/movement/make/Makefile b/movement/make/Makefile
-index 625c772..db08929 100644
+index da5486b..576822c 100644
--- a/movement/make/Makefile
+++ b/movement/make/Makefile
@@ -1,3 +1,5 @@
@@ -43,10 +45,10 @@ index 625c772..db08929 100644
TOP = ../..
include $(TOP)/make.mk
diff --git a/movement/movement.c b/movement/movement.c
-index 0c6ed31..ec20ce6 100644
+index 0b292a1..060f1e2 100644
--- a/movement/movement.c
+++ b/movement/movement.c
-@@ -52,6 +52,8 @@
+@@ -53,6 +53,8 @@
#include "alt_fw/the_stargazer.h"
#elif MOVEMENT_FIRMWARE == MOVEMENT_FIRMWARE_DEEP_SPACE_NOW
#include "alt_fw/deep_space_now.h"