summaryrefslogtreecommitdiffstats
path: root/main/jmm.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/jmm.patch')
-rw-r--r--main/jmm.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/main/jmm.patch b/main/jmm.patch
new file mode 100644
index 0000000..0bde666
--- /dev/null
+++ b/main/jmm.patch
@@ -0,0 +1,57 @@
+diff --git a/movement/alt_fw/jmm.h b/movement/alt_fw/jmm.h
+new file mode 100644
+index 0000000..878b4a4
+--- /dev/null
++++ b/movement/alt_fw/jmm.h
+@@ -0,0 +1,28 @@
++#ifndef MOVEMENT_CONFIG_H_
++#define MOVEMENT_CONFIG_H_
++
++#include "movement_faces.h"
++
++#define MOVEMENT_DEFAULT_RED_COLOR 0xf
++#define MOVEMENT_DEFAULT_GREEN_COLOR 0xf
++
++const watch_face_t watch_faces[] = {
++ simple_clock_face,
++ stock_stopwatch_face,
++ world_clock_face,
++ totp_face_lfs,
++ moon_phase_face,
++ sunrise_sunset_face,
++ decimal_time_face,
++ beats_face,
++ astronomy_face,
++ preferences_face,
++ frequency_correction_face,
++ set_time_face,
++};
++
++#define MOVEMENT_NUM_FACES (sizeof(watch_faces) / sizeof(watch_face_t))
++
++#define SIGNAL_TUNE_DEFAULT
++
++#endif // MOVEMENT_CONFIG_H_
+diff --git a/movement/make/Makefile b/movement/make/Makefile
+index 625c772..db08929 100644
+--- a/movement/make/Makefile
++++ b/movement/make/Makefile
+@@ -1,3 +1,5 @@
++FIRMWARE=JMM
++COLOR=RED
+ # Leave this line at the top of the file; it has all the watch library sources and includes.
+ TOP = ../..
+ include $(TOP)/make.mk
+diff --git a/movement/movement.c b/movement/movement.c
+index 0c6ed31..ec20ce6 100644
+--- a/movement/movement.c
++++ b/movement/movement.c
+@@ -52,6 +52,8 @@
+ #include "alt_fw/the_stargazer.h"
+ #elif MOVEMENT_FIRMWARE == MOVEMENT_FIRMWARE_DEEP_SPACE_NOW
+ #include "alt_fw/deep_space_now.h"
++#elif MOVEMENT_FIRMWARE == MOVEMENT_FIRMWARE_JMM
++#include "alt_fw/jmm.h"
+ #endif
+
+ #include "movement_custom_signal_tunes.h"