summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoey Castillo <joeycastillo@utexas.edu>2022-10-08 19:57:02 -0500
committerJoey Castillo <joeycastillo@utexas.edu>2022-10-08 19:57:02 -0500
commit1c89317c126a230a062e2e998f38fdfbe687f234 (patch)
tree4ea95625085bdb7a0543554ce53e7e45fd1a4587
parenta92238b159be62f9ef9f58f617e6f91189efc121 (diff)
parent33dec21cf1cb0ebd340e8d42253611540ca29b7c (diff)
downloadSensor-Watch-sensor-face-improvements.tar.gz
Sensor-Watch-sensor-face-improvements.tar.bz2
Sensor-Watch-sensor-face-improvements.zip
Merge branch 'main' of github.com:joeycastillo/Sensor-Watch into sensor-face-improvementssensor-face-improvements
-rw-r--r--make.mk1
-rw-r--r--rules.mk4
2 files changed, 4 insertions, 1 deletions
diff --git a/make.mk b/make.mk
index 0792e64f..25401642 100644
--- a/make.mk
+++ b/make.mk
@@ -159,6 +159,7 @@ else
CFLAGS += -W -Wall -Wextra -Wmissing-prototypes -Wmissing-declarations
CFLAGS += -Wno-format -Wno-unused-parameter
+CFLAGS += -MD -MP -MT $(BUILD)/$(*F).o -MF $(BUILD)/$(@F).d
INCLUDES += \
-I$(TOP)/boards/$(BOARD) \
diff --git a/rules.mk b/rules.mk
index 8de3fc1e..2c4acec1 100644
--- a/rules.mk
+++ b/rules.mk
@@ -1,3 +1,5 @@
+.SUFFIXES:
+
CFLAGS += $(INCLUDES) $(DEFINES)
OBJS = $(addprefix $(BUILD)/, $(notdir %/$(subst .c,.o, $(SRCS))))
@@ -60,6 +62,6 @@ clean:
analyze:
@$(COBRA) basic $(INCLUDES) $(DEFINES) $(SRCS)
-DEPFILES := $(SRCS:%.c=$(BUILD)/%.d)
+DEPFILES := $(OBJS:%.o=%.o.d)
-include $(wildcard $(DEPFILES))