summaryrefslogtreecommitdiffstats
path: root/movement/make
diff options
context:
space:
mode:
authorjoeycastillo <joeycastillo@utexas.edu>2023-01-25 09:26:31 -0600
committerGitHub <noreply@github.com>2023-01-25 09:26:31 -0600
commit4412b5d08f90084a8e677bea4792851e6d82bdf3 (patch)
treec1298f3ea924d8102b33bd796373209dad8be63b /movement/make
parent2b22ecc8e43cc21c56d82ee3f89f32dd7b6b8e4a (diff)
parent3303060c59e1591bd2c6bb7cfc5b21e550728d6d (diff)
downloadSensor-Watch-default-handler.tar.gz
Sensor-Watch-default-handler.tar.bz2
Sensor-Watch-default-handler.zip
Merge branch 'main' into default-handlerdefault-handler
Diffstat (limited to 'movement/make')
-rw-r--r--movement/make/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/movement/make/Makefile b/movement/make/Makefile
index 374c04be..58895862 100644
--- a/movement/make/Makefile
+++ b/movement/make/Makefile
@@ -22,6 +22,7 @@ INCLUDES += \
-I../lib/sunriset/ \
-I../lib/vsop87/ \
-I../lib/astrolib/ \
+ -I../lib/morsecalc/ \
# If you add any other source files you wish to compile, add them after ../app.c
# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
@@ -38,6 +39,10 @@ SRCS += \
../lib/sunriset/sunriset.c \
../lib/vsop87/vsop87a_milli.c \
../lib/astrolib/astrolib.c \
+ ../lib/morsecalc/calc.c \
+ ../lib/morsecalc/calc_fns.c \
+ ../lib/morsecalc/calc_strtof.c \
+ ../lib/morsecalc/mc.c \
../../littlefs/lfs.c \
../../littlefs/lfs_util.c \
../movement.c \
@@ -88,7 +93,9 @@ SRCS += \
../watch_faces/complication/tempchart_face.c \
../watch_faces/complication/tally_face.c \
../watch_faces/complication/tarot_face.c \
+ ../watch_faces/complication/morsecalc_face.c \
../watch_faces/complication/rpn_calculator_face.c \
+ ../watch_faces/complication/ships_bell_face.c \
# New watch faces go above this line.
# Leave this line at the bottom of the file; it has all the targets for making your project.