summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..e06b22c
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,26 @@
+
+
+APPDIRS=hello number update flash password dayfind 3ball
+
+APPS=${foreach appdir,${APPDIRS},${appdir}/${appdir}.app}
+PS=${APPS:%.app=%.p}
+LSTS=${APPS:%.app=%.lst}
+
+CROSS=../asl/
+
+AFLAGS=-i include -cpu datalink
+AS=${CROSS}asl ${AFLAGS}
+
+P2BIN=${CROSS}p2bin
+
+
+default:${APPS}
+
+%.app:%.p
+ ${P2BIN} $< $@ -r 0x110-\$$
+
+%.p:%.asm
+ ${AS} -L ${@:%.p=%.lst} -o $@ $<
+
+clean:
+ /bin/rm -f ${APPS} ${PS} ${LSTS}