aboutsummaryrefslogtreecommitdiffstats
path: root/tools/vnet/vnet-module/Makefile-2.6
diff options
context:
space:
mode:
authorKeir Fraser <keir@xen.org>2011-03-25 21:59:20 +0000
committerKeir Fraser <keir@xen.org>2011-03-25 21:59:20 +0000
commit2a738c3fe110a880835450c48fd9c3b5912f31f3 (patch)
tree3026f0b1dbb79596a865e08eeb38aa2b12f7631a /tools/vnet/vnet-module/Makefile-2.6
parent6102cace934c5ef156e7e1e21966cf3950dc40e5 (diff)
downloadxen-2a738c3fe110a880835450c48fd9c3b5912f31f3.tar.gz
xen-2a738c3fe110a880835450c48fd9c3b5912f31f3.tar.bz2
xen-2a738c3fe110a880835450c48fd9c3b5912f31f3.zip
tools: vnet: Remove
Build has been broken since at least 18969:d6889b3b6423 (early 2009) and it has been unhooked from the top level build since forever AFAICT. The last actual development (as opposed to tree wide cleanups and build fixes) appears to have been 11594:6d7bba6443ef in 2006. The functionality of vnet has apparently been superceded by VLANs, ebtables, Ethernet-over-IP etc all of which are well integrated with upstream kernels and distros. Signed-off-by: Ian Campbell <ian.campbell@citrix.com> Signed-off-by: Keir Fraser <keir@xen.org>
Diffstat (limited to 'tools/vnet/vnet-module/Makefile-2.6')
-rw-r--r--tools/vnet/vnet-module/Makefile-2.657
1 files changed, 0 insertions, 57 deletions
diff --git a/tools/vnet/vnet-module/Makefile-2.6 b/tools/vnet/vnet-module/Makefile-2.6
deleted file mode 100644
index f0b390c857..0000000000
--- a/tools/vnet/vnet-module/Makefile-2.6
+++ /dev/null
@@ -1,57 +0,0 @@
-# -*- mode: Makefile; -*-
-#============================================================================
-#
-# Copyright (C) 2004 Mike Wray <mike.wray@hp.com>
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by the
-# Free Software Foundation; either version 2 of the License, or (at your
-# option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
-# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
-#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free software Foundation, Inc.,
-# 59 Temple Place, suite 330, Boston, MA 02111-1307 USA
-#============================================================================
-
-#============================================================================
-# Vnet module makefile for 2.6 series kernels.
-
-LINUX_SERIES =2.6
-include Makefile.ver
-
-KERNEL_MODULE = vnet_module.ko
-
-#----------------------------------------------------------------------------
-#export KBUILD_VERBOSE=1
-
-.PHONY: all
-all: module module_version
-
-.PHONY: module
-module modules:
- $(MAKE) -C $(KERNEL_SRC) M=`pwd` modules
-
-.PHONY: module_version
-module_version:
- $(warning Module version $(shell strings $(KERNEL_MODULE) | grep vermagic))
-
-.PHONY: install install-module modules_install
-install install-module modules_install: module
- install -m 0755 -d $(DESTDIR)$(KERNEL_MODULE_DIR)
- install -m 0554 $(KERNEL_MODULE) $(DESTDIR)$(KERNEL_MODULE_DIR)
-
-.PHONY: clean
-clean:
- -@$(MAKE) -C $(KERNEL_SRC) M=$(PWD) clean
- -@$(RM) *.a *.o *.ko *~ .*.d .*.cmd *.mod.?
- -@$(RM) -r .tmp_versions
-
-.PHONY: TAGS
-TAGS:
- etags *.c *.h
-