aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/NRF51/NRF51822/platform.mk
diff options
context:
space:
mode:
authorStephane D'Alu <sdalu@sdalu.com>2016-02-09 19:12:08 +0100
committerStephane D'Alu <sdalu@sdalu.com>2016-02-09 19:12:08 +0100
commit709c28c9299e4464a0654443f87ce0180403fef8 (patch)
treef89584cc59624f885123e79591e266ad0b4f6d7c /os/hal/ports/NRF51/NRF51822/platform.mk
parent9a6ca01c850785363ea5051ffc18697c406109f8 (diff)
parentdb994ed1a671fe299499dc9ce0cd28cfebc2f409 (diff)
downloadChibiOS-Contrib-709c28c9299e4464a0654443f87ce0180403fef8.tar.gz
ChibiOS-Contrib-709c28c9299e4464a0654443f87ce0180403fef8.tar.bz2
ChibiOS-Contrib-709c28c9299e4464a0654443f87ce0180403fef8.zip
Merge branch 'master' into rng
Conflicts: os/hal/ports/NRF51/NRF51822/platform.mk
Diffstat (limited to 'os/hal/ports/NRF51/NRF51822/platform.mk')
-rw-r--r--os/hal/ports/NRF51/NRF51822/platform.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/os/hal/ports/NRF51/NRF51822/platform.mk b/os/hal/ports/NRF51/NRF51822/platform.mk
index 96dd630..663ca1f 100644
--- a/os/hal/ports/NRF51/NRF51822/platform.mk
+++ b/os/hal/ports/NRF51/NRF51822/platform.mk
@@ -28,6 +28,9 @@ endif
ifneq ($(findstring HAL_USE_GPT TRUE,$(HALCONF)),)
PLATFORMSRC += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822/gpt_lld.c
endif
+ifneq ($(findstring HAL_USE_WDG TRUE,$(HALCONF)),)
+PLATFORMSRC += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822/wdg_lld.c
+endif
ifneq ($(findstring HAL_USE_RNG TRUE,$(HALCONF)),)
PLATFORMSRC += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822/rng_lld.c
endif
@@ -43,9 +46,12 @@ PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822/i2c_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822/adc_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822/gpt_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822/wdg_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822/rng_lld.c
endif
# Required include directories
PLATFORMINC = ${CHIBIOS}/os/hal/ports/common/ARMCMx \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822
+
+