aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F0xx
diff options
context:
space:
mode:
authorbarthess <barthess@yandex.ru>2015-09-07 22:26:44 +0300
committerbarthess <barthess@yandex.ru>2015-09-07 22:26:44 +0300
commit51514b134ee5bfca3647647620920747b41eaf3a (patch)
tree045b1ddc975d11adbe3f82367d3f0cfc2f563011 /testhal/STM32/STM32F0xx
parent40014ce2c584274e5e1cee7d08f858bbfc0407f8 (diff)
downloadChibiOS-Contrib-51514b134ee5bfca3647647620920747b41eaf3a.tar.gz
ChibiOS-Contrib-51514b134ee5bfca3647647620920747b41eaf3a.tar.bz2
ChibiOS-Contrib-51514b134ee5bfca3647647620920747b41eaf3a.zip
STM32 testhal. Fixed paths in makefiles
Diffstat (limited to 'testhal/STM32/STM32F0xx')
-rw-r--r--testhal/STM32/STM32F0xx/onewire/.project2
-rw-r--r--testhal/STM32/STM32F0xx/onewire/Makefile1
-rw-r--r--testhal/STM32/STM32F0xx/onewire/halconf_community.h7
3 files changed, 8 insertions, 2 deletions
diff --git a/testhal/STM32/STM32F0xx/onewire/.project b/testhal/STM32/STM32F0xx/onewire/.project
index 856b65d..be76784 100644
--- a/testhal/STM32/STM32F0xx/onewire/.project
+++ b/testhal/STM32/STM32F0xx/onewire/.project
@@ -84,7 +84,7 @@
<link>
<name>os-git</name>
<type>2</type>
- <locationURI>PARENT-5-PROJECT_LOC/os</locationURI>
+ <locationURI>PARENT-5-PROJECT_LOC/ChibiOS-RT/os</locationURI>
</link>
</linkedResources>
</projectDescription>
diff --git a/testhal/STM32/STM32F0xx/onewire/Makefile b/testhal/STM32/STM32F0xx/onewire/Makefile
index a70bafa..a26473e 100644
--- a/testhal/STM32/STM32F0xx/onewire/Makefile
+++ b/testhal/STM32/STM32F0xx/onewire/Makefile
@@ -76,7 +76,6 @@ PROJECT = ch
# Imported source files and paths
CHIBIOS = ../../../../../ChibiOS-RT
-CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib/ChibiOS-RT
CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib
# Startup files.
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/startup_stm32f0xx.mk
diff --git a/testhal/STM32/STM32F0xx/onewire/halconf_community.h b/testhal/STM32/STM32F0xx/onewire/halconf_community.h
index e90257b..6c628c0 100644
--- a/testhal/STM32/STM32F0xx/onewire/halconf_community.h
+++ b/testhal/STM32/STM32F0xx/onewire/halconf_community.h
@@ -45,6 +45,13 @@
#define HAL_USE_EICU FALSE
#endif
+/**
+ * @brief Enables the community subsystem.
+ */
+#if !defined(HAL_USE_CRC) || defined(__DOXYGEN__)
+#define HAL_USE_CRC FALSE
+#endif
+
/*===========================================================================*/
/* FSMCNAND driver related settings. */
/*===========================================================================*/