aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--os/hal/ports/TIVA/TM4C123x/hal_lld.c4
-rw-r--r--os/hal/ports/TIVA/TM4C123x/hal_lld.h1
-rw-r--r--os/hal/ports/TIVA/TM4C123x/platform.mk4
3 files changed, 8 insertions, 1 deletions
diff --git a/os/hal/ports/TIVA/TM4C123x/hal_lld.c b/os/hal/ports/TIVA/TM4C123x/hal_lld.c
index 7a6046d..f259151 100644
--- a/os/hal/ports/TIVA/TM4C123x/hal_lld.c
+++ b/os/hal/ports/TIVA/TM4C123x/hal_lld.c
@@ -131,6 +131,10 @@ void tiva_clock_init(void)
#if HAL_USE_PWM
SYSCTL->RCC |= TIVA_PWM_FIELDS;
#endif
+
+#if defined(TIVA_UDMA_REQUIRED)
+ udmaInit();
+#endif
}
/**
diff --git a/os/hal/ports/TIVA/TM4C123x/hal_lld.h b/os/hal/ports/TIVA/TM4C123x/hal_lld.h
index d8b856f..72b53b4 100644
--- a/os/hal/ports/TIVA/TM4C123x/hal_lld.h
+++ b/os/hal/ports/TIVA/TM4C123x/hal_lld.h
@@ -349,6 +349,7 @@
/* Various helpers.*/
#include "nvic.h"
#include "tiva_isr.h"
+#include "tiva_udma.h"
#ifdef __cplusplus
extern "C" {
diff --git a/os/hal/ports/TIVA/TM4C123x/platform.mk b/os/hal/ports/TIVA/TM4C123x/platform.mk
index 3051cd3..0f54c5a 100644
--- a/os/hal/ports/TIVA/TM4C123x/platform.mk
+++ b/os/hal/ports/TIVA/TM4C123x/platform.mk
@@ -6,7 +6,9 @@ PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
${CHIBIOS}/community/os/hal/ports/TIVA/LLD/serial_lld.c \
${CHIBIOS}/community/os/hal/ports/TIVA/LLD/i2c_lld.c \
${CHIBIOS}/community/os/hal/ports/TIVA/LLD/gpt_lld.c \
- ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/pwm_lld.c
+ ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/pwm_lld.c \
+ ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/spi_lld.c \
+ ${CHISIOS}/community/os/hal/ports/TIVA/LLD/tiva_udma.c
# Required include directories
PLATFORMINC = ${CHIBIOS}/os/hal/ports/common/ARMCMx \