aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/templates/platform.mk
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2018-09-30 17:01:52 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2018-09-30 17:01:52 +0000
commit85d62cbdf68219a526aa4ee68c325adda8b8d67e (patch)
tree0d2293850986a464910ea05a7786acdd4d9a9d51 /os/hal/templates/platform.mk
parente100ea5b29ad86a12ef87aaf5c854dec17becfd4 (diff)
downloadChibiOS-85d62cbdf68219a526aa4ee68c325adda8b8d67e.tar.gz
ChibiOS-85d62cbdf68219a526aa4ee68c325adda8b8d67e.tar.bz2
ChibiOS-85d62cbdf68219a526aa4ee68c325adda8b8d67e.zip
Added WSPI-related code, updated halconf.h files.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@12311 110e8d01-0319-4d1e-a829-52ad28d1bb01
Diffstat (limited to 'os/hal/templates/platform.mk')
-rw-r--r--os/hal/templates/platform.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/os/hal/templates/platform.mk b/os/hal/templates/platform.mk
index 535e83b20..ee1d9e294 100644
--- a/os/hal/templates/platform.mk
+++ b/os/hal/templates/platform.mk
@@ -76,6 +76,9 @@ endif
ifneq ($(findstring HAL_USE_WDG TRUE,$(HALCONF)),)
PLATFORMSRC += ${CHIBIOS}/os/hal/templates/hal_wdg_lld.c
endif
+ifneq ($(findstring HAL_USE_WSPI TRUE,$(HALCONF)),)
+PLATFORMSRC += ${CHIBIOS}/os/hal/templates/hal_wspi_lld.c
+endif
else
PLATFORMSRC = ${CHIBIOS}/os/hal/templates/hal_lld.c \
${CHIBIOS}/os/hal/templates/hal_adc_lld.c \
@@ -100,7 +103,8 @@ PLATFORMSRC = ${CHIBIOS}/os/hal/templates/hal_lld.c \
${CHIBIOS}/os/hal/templates/hal_trng_lld.c \
${CHIBIOS}/os/hal/templates/hal_uart_lld.c \
${CHIBIOS}/os/hal/templates/hal_usb_lld.c \
- ${CHIBIOS}/os/hal/templates/hal_wdg_lld.c
+ ${CHIBIOS}/os/hal/templates/hal_wdg_lld.c \
+ ${CHIBIOS}/os/hal/templates/hal_wspi_lld.c
endif
# Required include directories