diff options
Diffstat (limited to 'os/hal/templates/platform.mk')
-rw-r--r-- | os/hal/templates/platform.mk | 6 |
1 files changed, 5 insertions, 1 deletions
diff --git a/os/hal/templates/platform.mk b/os/hal/templates/platform.mk index 535e83b20..ee1d9e294 100644 --- a/os/hal/templates/platform.mk +++ b/os/hal/templates/platform.mk @@ -76,6 +76,9 @@ endif ifneq ($(findstring HAL_USE_WDG TRUE,$(HALCONF)),)
PLATFORMSRC += ${CHIBIOS}/os/hal/templates/hal_wdg_lld.c
endif
+ifneq ($(findstring HAL_USE_WSPI TRUE,$(HALCONF)),)
+PLATFORMSRC += ${CHIBIOS}/os/hal/templates/hal_wspi_lld.c
+endif
else
PLATFORMSRC = ${CHIBIOS}/os/hal/templates/hal_lld.c \
${CHIBIOS}/os/hal/templates/hal_adc_lld.c \
@@ -100,7 +103,8 @@ PLATFORMSRC = ${CHIBIOS}/os/hal/templates/hal_lld.c \ ${CHIBIOS}/os/hal/templates/hal_trng_lld.c \
${CHIBIOS}/os/hal/templates/hal_uart_lld.c \
${CHIBIOS}/os/hal/templates/hal_usb_lld.c \
- ${CHIBIOS}/os/hal/templates/hal_wdg_lld.c
+ ${CHIBIOS}/os/hal/templates/hal_wdg_lld.c \
+ ${CHIBIOS}/os/hal/templates/hal_wspi_lld.c
endif
# Required include directories
|