aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/aplx6/config.h
diff options
context:
space:
mode:
authorAplyard <40563350+Aplyard@users.noreply.github.com>2020-04-13 22:13:41 +0300
committerGitHub <noreply@github.com>2020-04-13 12:13:41 -0700
commit4bccde37d4148bdf0ee3676c9eed102639cfeb4a (patch)
tree108db12c042ff59b0be75fab718a26aab381c983 /keyboards/aplx6/config.h
parentf6b40da7f854d461f30a3e525f4e36e51dac5db4 (diff)
downloadfirmware-4bccde37d4148bdf0ee3676c9eed102639cfeb4a.tar.gz
firmware-4bccde37d4148bdf0ee3676c9eed102639cfeb4a.tar.bz2
firmware-4bccde37d4148bdf0ee3676c9eed102639cfeb4a.zip
[Keyboard] Aplx6 (#8727)
* Create test.txt * aplx6 * Delete test.txt * fff * Delete ffff * test compile * Create README.md * edited * requests * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md * Update keyboards/aplx6/rules.mk * Update keyboards/aplx6/rules.mk * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md * pins update * update * update pins * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md
Diffstat (limited to 'keyboards/aplx6/config.h')
-rw-r--r--keyboards/aplx6/config.h49
1 files changed, 49 insertions, 0 deletions
diff --git a/keyboards/aplx6/config.h b/keyboards/aplx6/config.h
new file mode 100644
index 000000000..8db06d93c
--- /dev/null
+++ b/keyboards/aplx6/config.h
@@ -0,0 +1,49 @@
+/*
+Copyright 2020 April Aplyard <alex.fragiou@gmail.com>
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#pragma once
+
+#include "config_common.h"
+
+/* USB Device descriptor parameter */
+#define VENDOR_ID 0xE0E0
+#define PRODUCT_ID 0x0030
+#define DEVICE_VER 0x0001
+#define MANUFACTURER Aplyard
+#define PRODUCT Aplx6
+#define DESCRIPTION Aplx6 MediaPad
+
+/* key matrix size */
+#define MATRIX_ROWS 2
+#define MATRIX_COLS 3
+
+/* pin-out */
+#define MATRIX_ROW_PINS { E6, B3 }
+#define MATRIX_COL_PINS { F7, B6, F4 }
+#define UNUSED_PINS
+
+
+/* ws2812 RGB LED */
+//#define RGB_DI_PIN X
+
+//#define RGBLIGHT_ANIMATIONS
+//#define RGBLED_NUM X // Number of LEDs
+
+
+/* COL2ROW or ROW2COL */
+#define DIODE_DIRECTION COL2ROW
+