aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/clawsome/bookerboard/config.h
diff options
context:
space:
mode:
authorAlisGraveNil <63020540+AlisGraveNil@users.noreply.github.com>2020-05-18 15:45:52 -0400
committerGitHub <noreply@github.com>2020-05-18 20:45:52 +0100
commit4604c70c4c1a0cb2cebc010dba34b04e902bd982 (patch)
tree276e938643da89b7c0a1e6e9eaad59832efab986 /keyboards/clawsome/bookerboard/config.h
parent010c5b12bd0bc4a53abda6d8f9d77de8a7ef1e8f (diff)
downloadfirmware-4604c70c4c1a0cb2cebc010dba34b04e902bd982.tar.gz
firmware-4604c70c4c1a0cb2cebc010dba34b04e902bd982.tar.bz2
firmware-4604c70c4c1a0cb2cebc010dba34b04e902bd982.zip
[Keyboard] Add Bookerboard support (#9097)
* 5/14/20 first push for bookerboard * Update rules.mk * Update keyboards/clawsome/bookerboard/rules.mk Co-authored-by: ridingqwerty <george.g.koenig@gmail.com> * Update keyboards/clawsome/bookerboard/keymaps/default/keymap.c Co-authored-by: Joel Challis <git@zvecr.com> * Update keyboards/clawsome/bookerboard/config.h Co-authored-by: Ryan <fauxpark@gmail.com> * Update keyboards/clawsome/bookerboard/bookerboard.c Co-authored-by: Joel Challis <git@zvecr.com> * Update keyboards/clawsome/bookerboard/bookerboard.h Co-authored-by: ridingqwerty <george.g.koenig@gmail.com> * 5/15/20 * 2 * 3 * Update keyboards/clawsome/bookerboard/config.h Co-authored-by: Ryan <fauxpark@gmail.com> * Update keyboards/clawsome/bookerboard/config.h Co-authored-by: Ryan <fauxpark@gmail.com> * Update keyboards/clawsome/bookerboard/readme.md Co-authored-by: Ryan <fauxpark@gmail.com> * Update keyboards/clawsome/bookerboard/readme.md Co-authored-by: Joel Challis <git@zvecr.com> * Update keyboards/clawsome/bookerboard/readme.md Co-authored-by: Joel Challis <git@zvecr.com> Co-authored-by: ridingqwerty <george.g.koenig@gmail.com> Co-authored-by: Joel Challis <git@zvecr.com> Co-authored-by: Ryan <fauxpark@gmail.com>
Diffstat (limited to 'keyboards/clawsome/bookerboard/config.h')
-rw-r--r--keyboards/clawsome/bookerboard/config.h47
1 files changed, 47 insertions, 0 deletions
diff --git a/keyboards/clawsome/bookerboard/config.h b/keyboards/clawsome/bookerboard/config.h
new file mode 100644
index 000000000..19646e774
--- /dev/null
+++ b/keyboards/clawsome/bookerboard/config.h
@@ -0,0 +1,47 @@
+/*
+Copyright 2020 AAClawson (AlisGraveNil)
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#pragma once
+
+#include "config_common.h"
+
+/* USB Device descriptor parameter */
+#define VENDOR_ID 0xFEED
+#define PRODUCT_ID 0x41CE
+#define DEVICE_VER 0x0001
+#define MANUFACTURER AlisGraveNil
+#define PRODUCT Bookerboard
+#define DESCRIPTION A 12-key QMK-powered macropod
+
+/* key matrix size */
+#define MATRIX_ROWS 4
+#define MATRIX_COLS 3
+
+/*
+ * Keyboard Matrix Assignments
+ *
+ * Change this to how you wired your keyboard
+ * COLS: AVR pins used for columns, left to right
+ * ROWS: AVR pins used for rows, top to bottom
+ * DIODE_DIRECTION: COL2ROW = COL = Anode (+), ROW = Cathode (-, marked on diode)
+ * ROW2COL = ROW = Anode (+), COL = Cathode (-, marked on diode)
+ *
+ */
+#define MATRIX_ROW_PINS { B5, B4, E6, D7 }
+#define MATRIX_COL_PINS { B6, B2, B3 }
+
+#define DIODE_DIRECTION COL2ROW