aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/handwired/prime_exl_plus/prime_exl_plus.c
diff options
context:
space:
mode:
authorholtenc <holtenc@primekb.com>2020-02-25 15:21:59 -0600
committerGitHub <noreply@github.com>2020-02-25 13:21:59 -0800
commitd52cd8886c2b3d201c8cdb0bf1a45ba98e4d9cf0 (patch)
tree302a6a08b7eba42da5f36a4257ad564f26609708 /keyboards/handwired/prime_exl_plus/prime_exl_plus.c
parent61b71320f79a663880bd70402d306722c1bbfe3e (diff)
downloadfirmware-d52cd8886c2b3d201c8cdb0bf1a45ba98e4d9cf0.tar.gz
firmware-d52cd8886c2b3d201c8cdb0bf1a45ba98e4d9cf0.tar.bz2
firmware-d52cd8886c2b3d201c8cdb0bf1a45ba98e4d9cf0.zip
[Keyboard] Add Prime_EXL Plus to handwired (#8238)
* Add VIA support for Prime_L * Update keyboards/primekb/prime_l/v1/config.h * Add prime_exl_plus keyboard * Temporary removal of prime_exl_plus * Add Prime_EXL Plus, including VIA support * Update keyboards/handwired/prime_exl_plus/readme.md * Update keyboards/handwired/prime_exl_plus/readme.md * Update keyboards/handwired/prime_exl_plus/readme.md * Update keyboards/handwired/prime_exl_plus/rules.mk * Update keyboards/handwired/prime_exl_plus/info.json * Update keyboards/handwired/prime_exl_plus/info.json * Update keyboards/handwired/prime_exl_plus/info.json * Update keymap.c * correct spacing of keymaps and layout macro. move indicator logic from user space to keyboard space * further corrections to keymaps and layout macro. * Update keyboards/handwired/prime_exl_plus/prime_exl_plus.c * Update keyboards/handwired/prime_exl_plus/prime_exl_plus.c * Update keyboards/handwired/prime_exl_plus/prime_exl_plus.c * Update keyboards/handwired/prime_exl_plus/prime_exl_plus.c * Update prime_exl_plus.c * small edit to prime_exl_plus.c
Diffstat (limited to 'keyboards/handwired/prime_exl_plus/prime_exl_plus.c')
-rw-r--r--keyboards/handwired/prime_exl_plus/prime_exl_plus.c49
1 files changed, 49 insertions, 0 deletions
diff --git a/keyboards/handwired/prime_exl_plus/prime_exl_plus.c b/keyboards/handwired/prime_exl_plus/prime_exl_plus.c
new file mode 100644
index 000000000..266a3b638
--- /dev/null
+++ b/keyboards/handwired/prime_exl_plus/prime_exl_plus.c
@@ -0,0 +1,49 @@
+/* Copyright 2020 Holten Campbell
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#include "prime_exl_plus.h"
+
+void matrix_init_kb(void) {
+ // set CapsLock LED to output and low
+ setPinOutput(B0);
+ writePinLow(B0);
+ // set NumLock LED to output and low
+ setPinOutput(B1);
+ writePinLow(B1);
+ // set ScrollLock LED to output and low
+ setPinOutput(B2);
+ writePinLow(B2);
+}
+
+bool led_update_kb(led_t led_state) {
+ bool res = led_update_user(led_state);
+ if(res) {
+ writePin(B1, led_state.num_lock);
+ writePin(B0, led_state.caps_lock);
+ //writePin(B2, led_state.scroll_lock);
+ }
+ return res;
+}
+
+//function for layer indicator LED
+layer_state_t layer_state_set_kb(layer_state_t state)
+{
+ if (get_highest_layer(state) == 1) {
+ writePinHigh(B2);
+ } else {
+ writePinLow(B2);
+ }
+ return layer_state_set_user(state);
+}