aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/sol/keymaps/xulkal
diff options
context:
space:
mode:
authorXScorpion2 <rcalt2vt@gmail.com>2019-05-06 17:06:43 -0500
committerDrashna Jaelre <drashna@live.com>2019-05-06 15:06:43 -0700
commite01b2d518a1a08ce07278ef9a38c7a793c843749 (patch)
treebb63e0653e09308286d86df303c8d17a447df46c /keyboards/sol/keymaps/xulkal
parent99500243e10c12c0a5005da49aa1986947b27153 (diff)
downloadfirmware-e01b2d518a1a08ce07278ef9a38c7a793c843749.tar.gz
firmware-e01b2d518a1a08ce07278ef9a38c7a793c843749.tar.bz2
firmware-e01b2d518a1a08ce07278ef9a38c7a793c843749.zip
[Keyboard] Sol keyboard conversion to split common (#5773)
* Split common conversion * Updated serial and encoder pins * Fixing default folder until r2 * Fixing oled driver on slave split common * Fixing keymap compile errors * Fixing oled inactivity timer on slave split common * Hoisted oled driver task, init, & activity to keyboard.c * Update keyboards/sol/config.h Co-Authored-By: XScorpion2 <rcalt2vt@gmail.com> * Remove TAPPING_FORCE_HOLD
Diffstat (limited to 'keyboards/sol/keymaps/xulkal')
-rw-r--r--keyboards/sol/keymaps/xulkal/keymap.c12
-rw-r--r--keyboards/sol/keymaps/xulkal/rules.mk7
2 files changed, 7 insertions, 12 deletions
diff --git a/keyboards/sol/keymaps/xulkal/keymap.c b/keyboards/sol/keymaps/xulkal/keymap.c
index 4591034d2..111e8aa32 100644
--- a/keyboards/sol/keymaps/xulkal/keymap.c
+++ b/keyboards/sol/keymaps/xulkal/keymap.c
@@ -36,7 +36,7 @@ const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
_________________QWERTY_L3_________________, KC_GRV, KC_QUOT, _________________QWERTY_R3_________________, \
_________________QWERTY_L4_________________, RGB_TOG, RGBRST, _________________QWERTY_R4_________________, \
_________________QWERTY_L5_________________, RGB_RMOD, RGB_MOD, _________________QWERTY_R5_________________, \
- KC_VOLU, KC_VOLD, KC_SPC, KC_DEL, KC_ENT, KC_SPC, KC_VOLU, KC_VOLD \
+ KC_SPC, KC_DEL, KC_ENT, KC_SPC \
),
#ifndef GAMELAYER_DISABLE
@@ -46,7 +46,7 @@ const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
___________________GAME_L3_________________, KC_GRV, KC_QUOT, ___________________GAME_R3_________________, \
___________________GAME_L4_________________, RGB_TOG, RGBRST, ___________________GAME_R4_________________, \
___________________GAME_L5_________________, RGB_RMOD, RGB_MOD, ___________________GAME_R5_________________, \
- KC_VOLU, KC_VOLD, KC_SPC, KC_DEL, KC_ENT, KC_SPC, KC_VOLU, KC_VOLD \
+ KC_SPC, KC_DEL, KC_ENT, KC_SPC \
),
#endif
@@ -56,7 +56,7 @@ const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
__________________LOWER_L3_________________, _______, _______, __________________LOWER_R3_________________, \
__________________LOWER_L4_________________, _______, _______, __________________LOWER_R4_________________, \
__________________LOWER_L5_________________, _______, _______, __________________LOWER_R5_________________, \
- _______, _______, _______, _______, _______, _______, _______, _______ \
+ _______, _______, _______, _______ \
),
[_RAISE] = EXPAND_LAYOUT( \
@@ -65,7 +65,7 @@ const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
__________________RAISE_L3_________________, _______, _______, __________________RAISE_R3_________________, \
__________________RAISE_L4_________________, _______, _______, __________________RAISE_R4_________________, \
__________________RAISE_L5_________________, _______, _______, __________________RAISE_R5_________________, \
- _______, _______, _______, _______, _______, _______, _______, _______ \
+ _______, _______, _______, _______ \
),
#ifdef TRILAYER_ENABLED
@@ -75,7 +75,7 @@ const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
_________________ADJUST_L3_________________, _______, _______, _________________ADJUST_R3_________________, \
_________________ADJUST_L4_________________, _______, _______, _________________ADJUST_R4_________________, \
_________________ADJUST_L5_________________, _______, _______, _________________ADJUST_R5_________________, \
- _______, _______, _______, _______, _______, _______, _______, _______ \
+ _______, _______, _______, _______ \
),
#endif
};
@@ -158,7 +158,7 @@ static void render_status(void) {
}
void oled_task_user(void) {
- if (has_usb()) {
+ if (is_keyboard_master()) {
render_status();
} else {
render_logo();
diff --git a/keyboards/sol/keymaps/xulkal/rules.mk b/keyboards/sol/keymaps/xulkal/rules.mk
index 685b8ced9..c3ed98edb 100644
--- a/keyboards/sol/keymaps/xulkal/rules.mk
+++ b/keyboards/sol/keymaps/xulkal/rules.mk
@@ -16,17 +16,12 @@ RGB_MATRIX_KEYPRESSES = yes # Enable reactive per-key effects. Can be very l
RGBLIGHT_FULL_POWER = no # Allow maximum RGB brightness. Otherwise, limited to a safe level for a normal USB-A port
UNICODE_ENABLE = no # Unicode
SWAP_HANDS_ENABLE = no # Enable one-hand typing
-ENCODER_ENABLE_CUSTOM = no # Enable rotary encoder (+90)
OLED_DRIVER_ENABLE = yes # Enable the OLED Driver (+5000)
+ENCODER_ENABLE = no # Enable rotary encoder (+90)
IOS_DEVICE_ENABLE = no # Limit max brightness to connect to IOS device (iPad,iPhone)
# Do not edit past here
-ifeq ($(strip $(ENCODER_ENABLE_CUSTOM)), yes)
- OPT_DEFS += -DENCODER_ENABLE_CUSTOM
- SRC += common/knob_v2.c
-endif
-
ifeq ($(strip $(IOS_DEVICE_ENABLE)), yes)
OPT_DEFS += -DIOS_DEVICE_ENABLE
else ifeq ($(strip $(RGBLIGHT_FULL_POWER)), yes)