aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/ymdk/bface/rules.mk
diff options
context:
space:
mode:
authorEthan Durrant <5387347+emdarcher@users.noreply.github.com>2019-09-17 11:19:16 -0600
committerDrashna Jaelre <drashna@live.com>2019-09-17 10:19:16 -0700
commitd137fdea780a37395f397f9641fc7ebd2c7f27a0 (patch)
treecda0eaa187a45b6331b02d18e4eca3f0ba4e0bab /keyboards/ymdk/bface/rules.mk
parentab48ffd5c5923b822e789bb3b18d8a16654da91a (diff)
downloadfirmware-d137fdea780a37395f397f9641fc7ebd2c7f27a0.tar.gz
firmware-d137fdea780a37395f397f9641fc7ebd2c7f27a0.tar.bz2
firmware-d137fdea780a37395f397f9641fc7ebd2c7f27a0.zip
[Keyboard] Adding YMDK "Bface" keyboard (#6731)
* making a new board setup for ymdk bface clone * removing extra keymaps that copied over * documentation and edits for new ymdk_bface board * cleaning up config and keymaps * removed extra keymap and working on READMEs * readme edits * shorter aliexpress link in ymdk_bface readme * added images to readmes and edited the keymaps * more flashing directions * Mac directions formatting * editing and creating the all layout * cleanign up ymdk_bface keymaps * fixed typos in layout * removed tabs * cleaned up the LED and Backlight configuration. * adding more to info.josn and cleaning up readme * fixing JSON typos * made a ymdk folder and moved the bface into it. * fixing file names for the new folder structure
Diffstat (limited to 'keyboards/ymdk/bface/rules.mk')
-rw-r--r--keyboards/ymdk/bface/rules.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/keyboards/ymdk/bface/rules.mk b/keyboards/ymdk/bface/rules.mk
new file mode 100644
index 000000000..8f1f83f78
--- /dev/null
+++ b/keyboards/ymdk/bface/rules.mk
@@ -0,0 +1,33 @@
+# Copyright 2019 Ethan Durrant (emdarcher)
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+# MCU name
+MCU = atmega32a
+
+# build options
+BOOTMAGIC_ENABLE = no
+MOUSEKEY_ENABLE = yes
+EXTRAKEY_ENABLE = yes
+CONSOLE_ENABLE = no
+COMMAND_ENABLE = yes
+BACKLIGHT_ENABLE = yes
+BACKLIGHT_CUSTOM_DRIVER = no
+BACKLIGHT_BREATHING = no
+RGBLIGHT_ENABLE = no
+RGBLIGHT_CUSTOM_DRIVER = no
+
+OPT_DEFS = -DDEBUG_LEVEL=0
+BOOTLOADER = bootloadHID
+