aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/ymdk/bface/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/ymdk/bface/rules.mk')
-rw-r--r--keyboards/ymdk/bface/rules.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/keyboards/ymdk/bface/rules.mk b/keyboards/ymdk/bface/rules.mk
new file mode 100644
index 000000000..8f1f83f78
--- /dev/null
+++ b/keyboards/ymdk/bface/rules.mk
@@ -0,0 +1,33 @@
+# Copyright 2019 Ethan Durrant (emdarcher)
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+# MCU name
+MCU = atmega32a
+
+# build options
+BOOTMAGIC_ENABLE = no
+MOUSEKEY_ENABLE = yes
+EXTRAKEY_ENABLE = yes
+CONSOLE_ENABLE = no
+COMMAND_ENABLE = yes
+BACKLIGHT_ENABLE = yes
+BACKLIGHT_CUSTOM_DRIVER = no
+BACKLIGHT_BREATHING = no
+RGBLIGHT_ENABLE = no
+RGBLIGHT_CUSTOM_DRIVER = no
+
+OPT_DEFS = -DDEBUG_LEVEL=0
+BOOTLOADER = bootloadHID
+