aboutsummaryrefslogtreecommitdiffstats
path: root/layouts/community/ergodox
diff options
context:
space:
mode:
Diffstat (limited to 'layouts/community/ergodox')
-rw-r--r--layouts/community/ergodox/drashna/config.h15
-rw-r--r--layouts/community/ergodox/drashna/keymap.c41
-rw-r--r--layouts/community/ergodox/drashna/rules.mk17
-rw-r--r--layouts/community/ergodox/drashna_glow/config.h9
-rw-r--r--layouts/community/ergodox/drashna_glow/keymap.c2
-rw-r--r--layouts/community/ergodox/drashna_glow/rules.mk13
6 files changed, 44 insertions, 53 deletions
diff --git a/layouts/community/ergodox/drashna/config.h b/layouts/community/ergodox/drashna/config.h
index 0091ebcde..ce25b0646 100644
--- a/layouts/community/ergodox/drashna/config.h
+++ b/layouts/community/ergodox/drashna/config.h
@@ -6,10 +6,13 @@
# define RGBLIGHT_EFFECT_KNIGHT_LENGTH 3
# define RGBLIGHT_EFFECT_SNAKE_LENGTH 3
+# ifdef RGB_MATRIX_ENABLE
+# define RGBLIGHT_DISABLE_KEYCODES
+# endif
#endif // RGBLIGHT_ENABLE
#undef PRODUCT
-#define PRODUCT DrashnaDox - Hacked ErgoDox EZ Shine
+#define PRODUCT DrashnaDox - Hacked ErgoDox EZ Hybrid Monstrosity
#undef DEBOUNCE
#define DEBOUNCE 30
@@ -17,3 +20,13 @@
#define TAPPING_TERM_PER_KEY
#define ERGODOX_LED_30
+
+#ifdef RGB_MATRIX_ENABLE
+# undef RGB_MATRIX_LED_PROCESS_LIMIT
+# undef RGB_MATRIX_LED_FLUSH_LIMIT
+# if defined(RGBLIGHT_ENABLE) && defined(RGB_MATRIX_ENABLE)
+# define RGBLIGHT_LIMIT_VAL 175
+# define RGB_MATRIX_MAXIMUM_BRIGHTNESS (RGBLIGHT_LIMIT_VAL + 25)
+# undef RGBLIGHT_SLEEP
+# endif
+#endif
diff --git a/layouts/community/ergodox/drashna/keymap.c b/layouts/community/ergodox/drashna/keymap.c
index 8308bfdaa..69066a47c 100644
--- a/layouts/community/ergodox/drashna/keymap.c
+++ b/layouts/community/ergodox/drashna/keymap.c
@@ -280,7 +280,7 @@ const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
),
[_ADJUST] = LAYOUT_ergodox_pretty_wrapper(
- KC_MAKE, _______, _______, _______, _______, _______, _______, KC_NUKE, _________________ADJUST_R1_________________, KC_RST,
+ KC_MAKE, _______, _______, _______, _______, _______, UC_MOD, KC_NUKE, _________________ADJUST_R1_________________, KC_RST,
VRSN, _________________ADJUST_L1_________________, _______, _______, _______, _______, _______, _______, _______, EEP_RST,
_______, _________________ADJUST_L2_________________, _________________ADJUST_R2_________________, RGB_IDL,
_______, _________________ADJUST_L3_________________, _______, _______, _________________ADJUST_R3_________________, TG(_MODS),
@@ -382,31 +382,32 @@ void suspend_power_down_keymap(void) { rgb_matrix_set_suspend_state(true); }
void suspend_wakeup_init_keymap(void) { rgb_matrix_set_suspend_state(false); }
void rgb_matrix_indicators_user(void) {
- if (userspace_config.rgb_layer_change &&
-# ifdef RGB_DISABLE_WHEN_USB_SUSPENDED
- !g_suspend_state &&
-# endif
+ if (g_suspend_state || !rgb_matrix_config.enable) return;
+
+ if (layer_state_is(_GAMEPAD)) {
+ rgb_matrix_set_color(32, 0x00, 0xFF, 0x00); // Q
+ rgb_matrix_set_color(31, 0x00, 0xFF, 0xFF); // W
+ rgb_matrix_set_color(30, 0xFF, 0x00, 0x00); // E
+ rgb_matrix_set_color(29, 0xFF, 0x80, 0x00); // R
+ rgb_matrix_set_color(37, 0x00, 0xFF, 0xFF); // A
+ rgb_matrix_set_color(36, 0x00, 0xFF, 0xFF); // S
+ rgb_matrix_set_color(35, 0x00, 0xFF, 0xFF); // D
+ rgb_matrix_set_color(34, 0x7A, 0x00, 0xFF); // F
+
+ rgb_matrix_set_color(userspace_config.swapped_numbers ? 27 : 26, 0xFF, 0xFF, 0xFF); // 1
+ rgb_matrix_set_color(userspace_config.swapped_numbers ? 26 : 27, 0x00, 0xFF, 0x00); // 2
+ rgb_matrix_set_color(25, 0x7A, 0x00, 0xFF); // 3
+ }
+
# if defined(RGBLIGHT_ENABLE)
- (!rgblight_config.enable && rgb_matrix_config.enable)
+ if (!userspace_config.rgb_layer_change)
# else
- rgb_matrix_config.enable
+ if (userspace_config.rgb_layer_change)
# endif
- ) {
+ {
switch (get_highest_layer(layer_state)) {
case _GAMEPAD:
rgb_matrix_layer_helper(HSV_ORANGE, 1, rgb_matrix_config.speed, LED_FLAG_MODIFIER);
- rgb_matrix_set_color(32, 0x00, 0xFF, 0x00); // Q
- rgb_matrix_set_color(31, 0x00, 0xFF, 0xFF); // W
- rgb_matrix_set_color(30, 0xFF, 0x00, 0x00); // E
- rgb_matrix_set_color(29, 0xFF, 0x80, 0x00); // R
- rgb_matrix_set_color(37, 0x00, 0xFF, 0xFF); // A
- rgb_matrix_set_color(36, 0x00, 0xFF, 0xFF); // S
- rgb_matrix_set_color(35, 0x00, 0xFF, 0xFF); // D
- rgb_matrix_set_color(34, 0x7A, 0x00, 0xFF); // F
-
- rgb_matrix_set_color(userspace_config.swapped_numbers ? 27 : 26, 0xFF, 0xFF, 0xFF); // 1
- rgb_matrix_set_color(userspace_config.swapped_numbers ? 26 : 27, 0x00, 0xFF, 0x00); // 2
- rgb_matrix_set_color(25, 0x7A, 0x00, 0xFF); // 3
break;
case _DIABLO:
rgb_matrix_layer_helper(HSV_RED, 1, rgb_matrix_config.speed * 8, LED_FLAG_MODIFIER);
diff --git a/layouts/community/ergodox/drashna/rules.mk b/layouts/community/ergodox/drashna/rules.mk
index 3aee59df6..78a3d1584 100644
--- a/layouts/community/ergodox/drashna/rules.mk
+++ b/layouts/community/ergodox/drashna/rules.mk
@@ -1,19 +1,20 @@
-TAP_DANCE_ENABLE = yes
+BOOTMAGIC_ENABLE = lite
+TAP_DANCE_ENABLE = no
SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
COMMAND_ENABLE = no # Commands for debug and configuration
+CONSOLE_ENABLE = no
SPACE_CADET_ENABLE = no
+
ifeq ($(strip $(KEYBOARD)), ergodox_ez)
- RGBLIGHT_ENABLE = yes
- RGB_MATRIX_ENABLE = no
+ RGBLIGHT_ENABLE = yes
+ RGB_MATRIX_ENABLE = yes
+ RGBLIGHT_TWINKLE = no
+ INDICATOR_LIGHTS = no
+ RGBLIGHT_STARTUP_ANIMATION = no
endif
-CONSOLE_ENABLE = no
-BOOTMAGIC_ENABLE = yes
UNICODE_ENABLE = yes
UNICDOEMAP_ENABLE = no
-RGBLIGHT_TWINKLE = no
-INDICATOR_LIGHTS = no
-RGBLIGHT_STARTUP_ANIMATION = yes
DEBOUNCE_TYPE = eager_pr
diff --git a/layouts/community/ergodox/drashna_glow/config.h b/layouts/community/ergodox/drashna_glow/config.h
deleted file mode 100644
index 6431cb4ff..000000000
--- a/layouts/community/ergodox/drashna_glow/config.h
+++ /dev/null
@@ -1,9 +0,0 @@
-#pragma once
-
-#include "../drashna/config.h"
-
-#undef PRODUCT
-#define PRODUCT DrashnaDox - Hacked ErgoDox EZ Glow
-
-#undef RGB_MATRIX_LED_PROCESS_LIMIT
-#undef RGB_MATRIX_LED_FLUSH_LIMIT
diff --git a/layouts/community/ergodox/drashna_glow/keymap.c b/layouts/community/ergodox/drashna_glow/keymap.c
deleted file mode 100644
index 7d4bdbec5..000000000
--- a/layouts/community/ergodox/drashna_glow/keymap.c
+++ /dev/null
@@ -1,2 +0,0 @@
-/* placeholder file */
-#include QMK_KEYBOARD_H
diff --git a/layouts/community/ergodox/drashna_glow/rules.mk b/layouts/community/ergodox/drashna_glow/rules.mk
deleted file mode 100644
index 45addc7c2..000000000
--- a/layouts/community/ergodox/drashna_glow/rules.mk
+++ /dev/null
@@ -1,13 +0,0 @@
-USER_NAME := drashna
-
-CORRECTED_LAYOUT := $(LAYOUTS_REPO)/$(LAYOUT)/drashna
-
-SRC += $(CORRECTED_LAYOUT)/keymap.c
-
--include $(CORRECTED_LAYOUT)/rules.mk
-
-ifeq ($(strip $(KEYBOARD)), ergodox_ez)
- RGBLIGHT_ENABLE = no
- RGB_MATRIX_ENABLE = yes
-# TAP_DANCE_ENABLE = no
-endif