aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGennadiy Civil <misterg@google.com>2018-09-25 15:54:29 -0400
committerGennadiy Civil <misterg@google.com>2018-09-25 15:54:29 -0400
commitc159a7719ca3ed8c7c2323236eba49f035f7767d (patch)
tree68de7deac9aa8ef4a78e409dcdc6c200c3d45822
parente2f45b1bb85fab5db5326a1cd8feb8750765ab79 (diff)
downloadgoogletest-c159a7719ca3ed8c7c2323236eba49f035f7767d.tar.gz
googletest-c159a7719ca3ed8c7c2323236eba49f035f7767d.tar.bz2
googletest-c159a7719ca3ed8c7c2323236eba49f035f7767d.zip
autotools c++11
-rw-r--r--Makefile.am2
-rwxr-xr-xci/build-linux-autotools.sh2
2 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 433eefeb..dca37c85 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,6 @@
## Process this file with automake to produce Makefile.in
+AM_CXXFLAGS = -std=gnu++11
+
ACLOCAL_AMFLAGS = -I m4
AUTOMAKE_OPTIONS = foreign
diff --git a/ci/build-linux-autotools.sh b/ci/build-linux-autotools.sh
index 8954a4f0..385e8c21 100755
--- a/ci/build-linux-autotools.sh
+++ b/ci/build-linux-autotools.sh
@@ -39,6 +39,6 @@ autoreconf -i
# Run in a subdirectory to keep the sources clean
mkdir build || true
cd build
-../configure CXX="-std=c++11"
+../configure
make -j {NPROCESSORS:-2}