aboutsummaryrefslogtreecommitdiffstats
path: root/Projects
diff options
context:
space:
mode:
authorDean Camera <dean@fourwalledcubicle.com>2012-07-26 19:57:02 +0000
committerDean Camera <dean@fourwalledcubicle.com>2012-07-26 19:57:02 +0000
commita0024871401e92eefae41c9f94c9fbe91594747a (patch)
tree6bdd9f30cf83c20e08bd94416e1aac104cdec67b /Projects
parent16cd7c689674c710fafcb6aaa99ba78368987626 (diff)
downloadlufa-a0024871401e92eefae41c9f94c9fbe91594747a.tar.gz
lufa-a0024871401e92eefae41c9f94c9fbe91594747a.tar.bz2
lufa-a0024871401e92eefae41c9f94c9fbe91594747a.zip
Add hack to the XPLAINBridge project to allow it to compile even if an identical OBJDIR directory exists in the dependant AVRISP-MKII clone project folder.
Diffstat (limited to 'Projects')
-rw-r--r--Projects/XPLAINBridge/makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Projects/XPLAINBridge/makefile b/Projects/XPLAINBridge/makefile
index f51ada5dc..33ac357ed 100644
--- a/Projects/XPLAINBridge/makefile
+++ b/Projects/XPLAINBridge/makefile
@@ -29,6 +29,14 @@ LD_FLAGS =
# Default target
all:
+# Since this project borrows files from the AVRISP-MKII project which may also have an
+# identical OBJDIR directory, we need to enforce the use of this project's object file
+# directory as the one where the build object files are to be stored by pre-pending the
+# absolute path of the current project to the OBJDIR variable.
+ifneq ($(OBJDIR),)
+ override OBJDIR:=$(shell pwd)/$(OBJDIR)
+endif
+
# Include LUFA build script makefiles
include $(LUFA_PATH)/Build/lufa_core.mk
include $(LUFA_PATH)/Build/lufa_sources.mk