aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-10-06 15:50:19 +1000
committerinmarket <andrewh@inmarket.com.au>2014-10-06 15:50:19 +1000
commit18c4a9f8703b8a6ddcea050d74d31b194005dae1 (patch)
tree6101b238aeccc91ccb5331b3108e832bfbc0ff70 /boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile
parent2151935b3a89fdf357181f6f1161c1c0c1dde1f0 (diff)
downloaduGFX-18c4a9f8703b8a6ddcea050d74d31b194005dae1.tar.gz
uGFX-18c4a9f8703b8a6ddcea050d74d31b194005dae1.tar.bz2
uGFX-18c4a9f8703b8a6ddcea050d74d31b194005dae1.zip
Update support for ChibiOS v3 to the current repository.
Update Make system to match. Add ability to make to a library rather than a program Stop ignoring objcode invalid format errors Multiple make tidy ups
Diffstat (limited to 'boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile')
-rw-r--r--boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile9
1 files changed, 1 insertions, 8 deletions
diff --git a/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile b/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile
index ac483689..8baa399f 100644
--- a/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile
+++ b/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile
@@ -6,22 +6,16 @@
# General settings
# See $(GFXLIB)/tools/gmake_scripts/readme.txt for the list of variables
- OPT_VERBOSE_COMPILE = no
- OPT_GENERATE_LISTINGS = yes
- OPT_GENERATE_MAP = yes
- OPT_COPY_EXE = no
- OPT_LINK_OPTIMIZE = yes
- OPT_NONSTANDARD_FLAGS = no
OPT_NATIVEOS = chibios
OPT_OS = chibios
OPT_THUMB = yes
+ OPT_LINK_OPTIMIZE = yes
OPT_CPU = stm32m4
# uGFX settings
# See $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk for the list of variables
GFXLIB = ../uGFX
GFXBOARD = Mikromedia-STM32-M4-ILI9341
- #GFXDRIVERS = multiple/uGFXnet
GFXDEMO = modules/gdisp/basics
# ChibiOS settings
@@ -31,7 +25,6 @@ ifeq ($(OPT_OS),chibios)
CHIBIOS_BOARD =
CHIBIOS_PLATFORM = STM32F4xx
CHIBIOS_PORT = GCC/ARMCMx/STM32F4xx
- CHIBIOS_DEFS =
CHIBIOS_LDSCRIPT = STM32F407xG.ld
# We define a non standard board script as this is not a standard ChibiOS supported board
include $(GFXLIB)/boards/base/Mikromedia-STM32-M4-ILI9341/ChibiOS_Board/board.mk