aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile')
-rw-r--r--boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile9
1 files changed, 1 insertions, 8 deletions
diff --git a/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile b/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile
index ac483689..8baa399f 100644
--- a/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile
+++ b/boards/base/Mikromedia-STM32-M4-ILI9341/example_chibios_2.x/Makefile
@@ -6,22 +6,16 @@
# General settings
# See $(GFXLIB)/tools/gmake_scripts/readme.txt for the list of variables
- OPT_VERBOSE_COMPILE = no
- OPT_GENERATE_LISTINGS = yes
- OPT_GENERATE_MAP = yes
- OPT_COPY_EXE = no
- OPT_LINK_OPTIMIZE = yes
- OPT_NONSTANDARD_FLAGS = no
OPT_NATIVEOS = chibios
OPT_OS = chibios
OPT_THUMB = yes
+ OPT_LINK_OPTIMIZE = yes
OPT_CPU = stm32m4
# uGFX settings
# See $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk for the list of variables
GFXLIB = ../uGFX
GFXBOARD = Mikromedia-STM32-M4-ILI9341
- #GFXDRIVERS = multiple/uGFXnet
GFXDEMO = modules/gdisp/basics
# ChibiOS settings
@@ -31,7 +25,6 @@ ifeq ($(OPT_OS),chibios)
CHIBIOS_BOARD =
CHIBIOS_PLATFORM = STM32F4xx
CHIBIOS_PORT = GCC/ARMCMx/STM32F4xx
- CHIBIOS_DEFS =
CHIBIOS_LDSCRIPT = STM32F407xG.ld
# We define a non standard board script as this is not a standard ChibiOS supported board
include $(GFXLIB)/boards/base/Mikromedia-STM32-M4-ILI9341/ChibiOS_Board/board.mk