aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base/OSX/example/Makefile
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-10-04 17:12:33 +1000
committerinmarket <andrewh@inmarket.com.au>2014-10-04 17:12:33 +1000
commit2151935b3a89fdf357181f6f1161c1c0c1dde1f0 (patch)
treefa8cac4a2ffc994dd91de3fbc6f4090677ddf65e /boards/base/OSX/example/Makefile
parent5d3ab261c0f994b25013f73b4fd9794d81740da7 (diff)
downloaduGFX-2151935b3a89fdf357181f6f1161c1c0c1dde1f0.tar.gz
uGFX-2151935b3a89fdf357181f6f1161c1c0c1dde1f0.tar.bz2
uGFX-2151935b3a89fdf357181f6f1161c1c0c1dde1f0.zip
Update to makefiles to support ChibiOS v3, making ARM thumb targets, CPU specific flags etc
Also put license in the gmake master scripts.
Diffstat (limited to 'boards/base/OSX/example/Makefile')
-rw-r--r--boards/base/OSX/example/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/boards/base/OSX/example/Makefile b/boards/base/OSX/example/Makefile
index 956608ff..5bbcb5df 100644
--- a/boards/base/OSX/example/Makefile
+++ b/boards/base/OSX/example/Makefile
@@ -24,7 +24,7 @@
# OSX settings
# See $(GFXLIB)/tools/gmake_scripts/os_osx.mk for the list of variables
OSX_SDK = /Developer/SDKs/MacOSX10.7.sdk
- OSX_ARCH = -mmacosx-version-min=10.3 -arch i386
+ OSX_ARCH = -mmacosx-version-min=10.3
##############################################################################################
# Set these for your project
@@ -32,13 +32,13 @@
ARCH =
SRCFLAGS = -ggdb -O0
-SRCFLAGS+= -m32
CFLAGS =
CXXFLAGS =
ASFLAGS =
LDFLAGS =
SRC =
+OBJS =
DEFS =
LIBS =
INCPATH =