aboutsummaryrefslogtreecommitdiffstats
path: root/boards
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-02-19 00:19:38 +1000
committerinmarket <andrewh@inmarket.com.au>2014-02-19 00:19:38 +1000
commit6dd606fc2f2e7a6bef7d7ac772c7f97a35f8a61b (patch)
tree8f50ff0c0b4f7a8f91b6053f767ea4f16ee48ffb /boards
parentd4c2656e60c8218cb42d50d16c405c146fb61fce (diff)
downloaduGFX-6dd606fc2f2e7a6bef7d7ac772c7f97a35f8a61b.tar.gz
uGFX-6dd606fc2f2e7a6bef7d7ac772c7f97a35f8a61b.tar.bz2
uGFX-6dd606fc2f2e7a6bef7d7ac772c7f97a35f8a61b.zip
Add demo makefiles and update example master makefiles to match.
Diffstat (limited to 'boards')
-rw-r--r--boards/base/Linux/example/Makefile8
-rw-r--r--boards/base/Mikromedia-STM32-M4-ILI9341/example/Makefile7
-rw-r--r--boards/base/Olimex-SAM7EX256-GE8/example/Makefile7
-rw-r--r--boards/base/Win32/example/Makefile7
4 files changed, 20 insertions, 9 deletions
diff --git a/boards/base/Linux/example/Makefile b/boards/base/Linux/example/Makefile
index 1d59fe43..e454a811 100644
--- a/boards/base/Linux/example/Makefile
+++ b/boards/base/Linux/example/Makefile
@@ -52,9 +52,11 @@ include ${GFXLIB}/gfx.mk
include ${GFXLIB}/boards/base/Linux/board.mk
# Where is our source code - alter these for your project.
-MYFILES = $(GFXLIB)/demos/modules/gdisp/basics
-MYCSRC = $(MYFILES)/main.c
-MYDEFS =
+# Either just include the demo makefile or add your own definitions
+include $(GFXLIB)/demos/modules/gdisp/basics/demo.mk
+#MYFILES = my-project-directory
+#MYCSRC = $(MYFILES)/main.c
+#MYDEFS =
# List all user C define here, like -D_DEBUG=1
UDEFS = $(MYDEFS) $(GFXDEFS)
diff --git a/boards/base/Mikromedia-STM32-M4-ILI9341/example/Makefile b/boards/base/Mikromedia-STM32-M4-ILI9341/example/Makefile
index c5f88f61..1c314543 100644
--- a/boards/base/Mikromedia-STM32-M4-ILI9341/example/Makefile
+++ b/boards/base/Mikromedia-STM32-M4-ILI9341/example/Makefile
@@ -82,8 +82,11 @@ include $(GFXLIB)/boards/base/Mikromedia-STM32-M4-ILI9341/ChibiOS_Board/board.mk
include $(GFXLIB)/gfx.mk
# Where is our source code - alter these for your project.
-MYFILES = $(GFXLIB)/demos/modules/gdisp/basics
-MYCSRC = $(MYFILES)/main.c
+# Either just include the demo makefile or add your own definitions
+include $(GFXLIB)/demos/modules/gdisp/basics/demo.mk
+#MYFILES = my-project-directory
+#MYCSRC = $(MYFILES)/main.c
+#MYDEFS =
# C sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
diff --git a/boards/base/Olimex-SAM7EX256-GE8/example/Makefile b/boards/base/Olimex-SAM7EX256-GE8/example/Makefile
index d6161d5e..b7b4da1c 100644
--- a/boards/base/Olimex-SAM7EX256-GE8/example/Makefile
+++ b/boards/base/Olimex-SAM7EX256-GE8/example/Makefile
@@ -64,8 +64,11 @@ include $(GFXLIB)/gfx.mk
include $(GFXLIB)/boards/base/Olimex-SAM7EX256-GE8/board.mk
# Where is our source code - alter these for your project.
-MYFILES = $(GFXLIB)/demos/modules/gdisp/basics
-MYCSRC = $(MYFILES)/main.c
+# Either just include the demo makefile or add your own definitions
+include $(GFXLIB)/demos/modules/gdisp/basics/demo.mk
+#MYFILES = my-project-directory
+#MYCSRC = $(MYFILES)/main.c
+#MYDEFS =
# C sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
diff --git a/boards/base/Win32/example/Makefile b/boards/base/Win32/example/Makefile
index 5badd338..94a99caf 100644
--- a/boards/base/Win32/example/Makefile
+++ b/boards/base/Win32/example/Makefile
@@ -76,8 +76,11 @@ else
endif
# Where is our source code - alter these for your project.
-MYFILES = $(GFXLIB)/demos/modules/gdisp/basics
-MYCSRC = $(MYFILES)/main.c
+# Either just include the demo makefile or add your own definitions
+include $(GFXLIB)/demos/modules/gdisp/basics/demo.mk
+#MYFILES = my-project-directory
+#MYCSRC = $(MYFILES)/main.c
+#MYDEFS =
# List C source files here
SRC += ${GFXSRC} \