aboutsummaryrefslogtreecommitdiffstats
path: root/boards
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-04-12 13:58:30 +1000
committerinmarket <andrewh@inmarket.com.au>2014-04-12 13:58:30 +1000
commite0e2b2a3d97f327fbeec7883aab2a512c442b1a1 (patch)
treedd6422e3448ce392e247f18d8143051fbf074e55 /boards
parentfb8d159749daa8aefa75615d2f8a6cca2fac9ec0 (diff)
downloaduGFX-e0e2b2a3d97f327fbeec7883aab2a512c442b1a1.tar.gz
uGFX-e0e2b2a3d97f327fbeec7883aab2a512c442b1a1.tar.bz2
uGFX-e0e2b2a3d97f327fbeec7883aab2a512c442b1a1.zip
Changes to example makefiles and other files for ChibiOS due to changes in ChibiOS-2.6.x
Diffstat (limited to 'boards')
-rw-r--r--boards/base/Mikromedia-STM32-M4-ILI9341/example/Makefile1
-rw-r--r--boards/base/Mikromedia-STM32-M4-ILI9341/example/mcuconf.h5
-rw-r--r--boards/base/Olimex-SAM7EX256-GE8/example/Makefile1
3 files changed, 6 insertions, 1 deletions
diff --git a/boards/base/Mikromedia-STM32-M4-ILI9341/example/Makefile b/boards/base/Mikromedia-STM32-M4-ILI9341/example/Makefile
index 1c314543..0ca152c6 100644
--- a/boards/base/Mikromedia-STM32-M4-ILI9341/example/Makefile
+++ b/boards/base/Mikromedia-STM32-M4-ILI9341/example/Makefile
@@ -153,6 +153,7 @@ LD = $(TRGT)gcc
CP = $(TRGT)objcopy
AS = $(TRGT)gcc -x assembler-with-cpp
OD = $(TRGT)objdump
+SZ = $(TRGT)size
HEX = $(CP) -O ihex
BIN = $(CP) -O binary
diff --git a/boards/base/Mikromedia-STM32-M4-ILI9341/example/mcuconf.h b/boards/base/Mikromedia-STM32-M4-ILI9341/example/mcuconf.h
index 64895943..c92d2970 100644
--- a/boards/base/Mikromedia-STM32-M4-ILI9341/example/mcuconf.h
+++ b/boards/base/Mikromedia-STM32-M4-ILI9341/example/mcuconf.h
@@ -29,6 +29,10 @@
*/
#define STM32F4xx_MCUCONF
+#define STM32F40_41xxx
+
+// Define this if you are using an older ChibiOS version
+//#define STM32_VOS STM32_VOS_HIGH
/*
* HAL driver system settings.
@@ -57,7 +61,6 @@
#define STM32_I2SSRC STM32_I2SSRC_CKIN
#define STM32_PLLI2SN_VALUE 192
#define STM32_PLLI2SR_VALUE 5
-#define STM32_VOS STM32_VOS_HIGH
#define STM32_PVD_ENABLE FALSE
#define STM32_PLS STM32_PLS_LEV0
#define STM32_BKPRAM_ENABLE FALSE
diff --git a/boards/base/Olimex-SAM7EX256-GE8/example/Makefile b/boards/base/Olimex-SAM7EX256-GE8/example/Makefile
index b7b4da1c..e9fdde2d 100644
--- a/boards/base/Olimex-SAM7EX256-GE8/example/Makefile
+++ b/boards/base/Olimex-SAM7EX256-GE8/example/Makefile
@@ -136,6 +136,7 @@ LD = $(TRGT)gcc
CP = $(TRGT)objcopy
AS = $(TRGT)gcc -x assembler-with-cpp
OD = $(TRGT)objdump
+SZ = $(TRGT)size
HEX = $(CP) -O ihex
BIN = $(CP) -O binary