aboutsummaryrefslogtreecommitdiffstats
path: root/include/gfx.h
diff options
context:
space:
mode:
authorAndrew Hannam <andrewh@inmarket.com.au>2013-01-16 20:41:18 -0800
committerAndrew Hannam <andrewh@inmarket.com.au>2013-01-16 20:41:18 -0800
commit7cce52d2f6b874895e3cdd557c4523eeeae942bf (patch)
tree5fe956e67796778248d32d7f4ddaa5dfb08b54c6 /include/gfx.h
parent8b5c073ea6f8491ce4176fb2996f74b3222f8188 (diff)
parent1a05e4a89ad7351e81da0e4dd152a7375a457884 (diff)
downloaduGFX-7cce52d2f6b874895e3cdd557c4523eeeae942bf.tar.gz
uGFX-7cce52d2f6b874895e3cdd557c4523eeeae942bf.tar.bz2
uGFX-7cce52d2f6b874895e3cdd557c4523eeeae942bf.zip
Merge pull request #14 from Tectu/master
Merge Tectu Changes
Diffstat (limited to 'include/gfx.h')
-rw-r--r--include/gfx.h11
1 files changed, 11 insertions, 0 deletions
diff --git a/include/gfx.h b/include/gfx.h
index 9dfe681a..c4c670f8 100644
--- a/include/gfx.h
+++ b/include/gfx.h
@@ -46,6 +46,15 @@
#define GFX_USE_GDISP FALSE
#endif
/**
+ * @brief GFX Text Display Basic API
+ * @details Defaults to FALSE
+ * @note Also add the specific hardware driver to your makefile.
+ * Eg. include $(GFXLIB)/drivers/tdisp/HD44780/tdisp_lld.mk
+ */
+ #ifndef GFX_USE_TDISP
+ #define GFX_USE_TDISP FALSE
+ #endif
+ /**
* @brief GFX Graphics Windowing API
* @details Defaults to FALSE
* @details Extends the GDISP API to add the concept of graphic windows.
@@ -94,6 +103,7 @@
#include "gdisp/options.h"
#include "gwin/options.h"
#include "ginput/options.h"
+#include "tdisp/options.h"
/**
* Inter-dependancy safety checks on the sub-systems.
@@ -109,6 +119,7 @@
#include "gdisp/gdisp.h"
#include "gwin/gwin.h"
#include "ginput/ginput.h"
+#include "tdisp/tdisp.h"
#endif /* _GFX_H */
/** @} */