aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJoel Bodenmann <joel@unormal.org>2013-01-13 10:57:33 +0100
committerJoel Bodenmann <joel@unormal.org>2013-01-13 10:57:33 +0100
commitc3006aa89c92184ab90974f6649cfa24d9e53fd4 (patch)
tree3b6786d6ef9bd9d091b4108919fbe0b640e05145 /include
parent83ba8748bccb7da9ac39f59d26a46cac7909a601 (diff)
downloaduGFX-c3006aa89c92184ab90974f6649cfa24d9e53fd4.tar.gz
uGFX-c3006aa89c92184ab90974f6649cfa24d9e53fd4.tar.bz2
uGFX-c3006aa89c92184ab90974f6649cfa24d9e53fd4.zip
small fix
Diffstat (limited to 'include')
-rw-r--r--include/gfx.h9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/gfx.h b/include/gfx.h
index b6107de6..c4c670f8 100644
--- a/include/gfx.h
+++ b/include/gfx.h
@@ -46,6 +46,15 @@
#define GFX_USE_GDISP FALSE
#endif
/**
+ * @brief GFX Text Display Basic API
+ * @details Defaults to FALSE
+ * @note Also add the specific hardware driver to your makefile.
+ * Eg. include $(GFXLIB)/drivers/tdisp/HD44780/tdisp_lld.mk
+ */
+ #ifndef GFX_USE_TDISP
+ #define GFX_USE_TDISP FALSE
+ #endif
+ /**
* @brief GFX Graphics Windowing API
* @details Defaults to FALSE
* @details Extends the GDISP API to add the concept of graphic windows.