aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/ginput/touch/FT5x06
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/ginput/touch/FT5x06')
-rw-r--r--drivers/ginput/touch/FT5x06/driver.mk1
-rw-r--r--drivers/ginput/touch/FT5x06/gmouse_lld_FT5x06.c4
2 files changed, 2 insertions, 3 deletions
diff --git a/drivers/ginput/touch/FT5x06/driver.mk b/drivers/ginput/touch/FT5x06/driver.mk
index 741464e8..fc227e8b 100644
--- a/drivers/ginput/touch/FT5x06/driver.mk
+++ b/drivers/ginput/touch/FT5x06/driver.mk
@@ -1,2 +1 @@
-# List the required driver.
GFXSRC += $(GFXLIB)/drivers/ginput/touch/FT5x06/gmouse_lld_FT5x06.c
diff --git a/drivers/ginput/touch/FT5x06/gmouse_lld_FT5x06.c b/drivers/ginput/touch/FT5x06/gmouse_lld_FT5x06.c
index da7c46ed..dbd5981c 100644
--- a/drivers/ginput/touch/FT5x06/gmouse_lld_FT5x06.c
+++ b/drivers/ginput/touch/FT5x06/gmouse_lld_FT5x06.c
@@ -10,13 +10,13 @@
#if GFX_USE_GINPUT && GINPUT_NEED_MOUSE
#define GMOUSE_DRIVER_VMT GMOUSEVMT_FT5x06
-#include "src/ginput/ginput_driver_mouse.h"
+#include "../../../../src/ginput/ginput_driver_mouse.h"
// Get the hardware interface
#include "gmouse_lld_FT5x06_board.h"
// Hardware definitions
-#include "drivers/ginput/touch/FT5x06/ft5x06.h"
+#include "ft5x06.h"
static bool_t MouseInit(GMouse* m, unsigned driverinstance) {
if (!init_board(m, driverinstance))