aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2014-01-03 09:06:36 -0800
committerPaul Kehrer <paul.l.kehrer@gmail.com>2014-01-03 09:06:36 -0800
commit23e532652d67e260cbf1078165ee72de2f35539c (patch)
tree4d80d4b36b6f9adae2e3824d407fae55ec140c67
parentadbea0d9456dd9261ef59c3c0f2e3466a3937686 (diff)
parent7630d6c50b3112eae69de606760cfb3e3b070c26 (diff)
downloadcryptography-23e532652d67e260cbf1078165ee72de2f35539c.tar.gz
cryptography-23e532652d67e260cbf1078165ee72de2f35539c.tar.bz2
cryptography-23e532652d67e260cbf1078165ee72de2f35539c.zip
Merge pull request #397 from alex/long-description
Include a long description in our setup.py
-rw-r--r--setup.py13
1 files changed, 11 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 1856cadb..3202f843 100644
--- a/setup.py
+++ b/setup.py
@@ -10,12 +10,16 @@
# implied.
# See the License for the specific language governing permissions and
# limitations under the License.
+import os
+
from setuptools import setup, find_packages
+base_dir = os.path.dirname(__file__)
+
about = {}
-with open("cryptography/__about__.py") as fp:
- exec(fp.read(), about)
+with open(os.path.join(base_dir, "cryptography", "__about__.py")) as f:
+ exec(f.read(), about)
CFFI_DEPENDENCY = "cffi>=0.6"
@@ -30,11 +34,16 @@ setup_requires = [
CFFI_DEPENDENCY,
]
+with open(os.path.join(base_dir, "README.rst")) as f:
+ long_description = f.read()
+
+
setup(
name=about["__title__"],
version=about["__version__"],
description=about["__summary__"],
+ long_description=long_description,
license=about["__license__"],
url=about["__uri__"],