aboutsummaryrefslogtreecommitdiffstats
path: root/docs/hazmat
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2014-01-03 15:03:17 -0800
committerAlex Gaynor <alex.gaynor@gmail.com>2014-01-03 15:03:17 -0800
commit327742c8e6271e2b6d809e891bd8e518b89994d9 (patch)
tree324a70bd84ddbc3490f20c0e3413ef1ecc6e3315 /docs/hazmat
parenteba623f88260a9a076ce3a4a71d1d61755327e05 (diff)
parentf96db83a64bb0ac40d04d27383d7c2defbcec491 (diff)
downloadcryptography-327742c8e6271e2b6d809e891bd8e518b89994d9.tar.gz
cryptography-327742c8e6271e2b6d809e891bd8e518b89994d9.tar.bz2
cryptography-327742c8e6271e2b6d809e891bd8e518b89994d9.zip
Merge branch 'master' into setup-install-extension
Conflicts: setup.py
Diffstat (limited to 'docs/hazmat')
-rw-r--r--docs/hazmat/bindings/index.rst2
-rw-r--r--docs/hazmat/primitives/hmac.rst9
2 files changed, 7 insertions, 4 deletions
diff --git a/docs/hazmat/bindings/index.rst b/docs/hazmat/bindings/index.rst
index 809eddfc..e2a17591 100644
--- a/docs/hazmat/bindings/index.rst
+++ b/docs/hazmat/bindings/index.rst
@@ -6,7 +6,7 @@ Bindings
.. currentmodule:: cryptography.hazmat.bindings
``cryptography`` aims to provide low-level CFFI based bindings to multiple
-native C libraries. These provide no automatic initialisation of the library
+native C libraries. These provide no automatic initialization of the library
and may not provide complete wrappers for its API.
Using these functions directly is likely to require you to be careful in
diff --git a/docs/hazmat/primitives/hmac.rst b/docs/hazmat/primitives/hmac.rst
index b8f94fd2..dc5c54f8 100644
--- a/docs/hazmat/primitives/hmac.rst
+++ b/docs/hazmat/primitives/hmac.rst
@@ -74,8 +74,11 @@ message.
.. method:: verify(signature)
- Finalize the current context and securely compare digest to ``signature``.
+ Finalize the current context and securely compare digest to
+ ``signature``.
- :param bytes signature: The bytes of the HMAC signature recieved.
+ :param bytes signature: The bytes to compare the current digest
+ against.
:raises cryptography.exceptions.AlreadyFinalized: See :meth:`finalize`
- :raises cryptography.exceptions.InvalidSignature: If signature does not match digest
+ :raises cryptography.exceptions.InvalidSignature: If signature does not
+ match digest