aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2014-01-03 15:03:17 -0800
committerAlex Gaynor <alex.gaynor@gmail.com>2014-01-03 15:03:17 -0800
commit327742c8e6271e2b6d809e891bd8e518b89994d9 (patch)
tree324a70bd84ddbc3490f20c0e3413ef1ecc6e3315 /setup.py
parenteba623f88260a9a076ce3a4a71d1d61755327e05 (diff)
parentf96db83a64bb0ac40d04d27383d7c2defbcec491 (diff)
downloadcryptography-327742c8e6271e2b6d809e891bd8e518b89994d9.tar.gz
cryptography-327742c8e6271e2b6d809e891bd8e518b89994d9.tar.bz2
cryptography-327742c8e6271e2b6d809e891bd8e518b89994d9.zip
Merge branch 'master' into setup-install-extension
Conflicts: setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 10 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 2ff57e97..fe37d9fb 100644
--- a/setup.py
+++ b/setup.py
@@ -10,14 +10,17 @@
# implied.
# See the License for the specific language governing permissions and
# limitations under the License.
+import os
from distutils.command.build import build
from setuptools import setup, find_packages
+base_dir = os.path.dirname(__file__)
+
about = {}
-with open("cryptography/__about__.py") as fp:
- exec(fp.read(), about)
+with open(os.path.join(base_dir, "cryptography", "__about__.py")) as f:
+ exec(f.read(), about)
CFFI_DEPENDENCY = "cffi>=0.6"
@@ -42,11 +45,16 @@ class cffi_build(build):
build.finalize_options(self)
+with open(os.path.join(base_dir, "README.rst")) as f:
+ long_description = f.read()
+
+
setup(
name=about["__title__"],
version=about["__version__"],
description=about["__summary__"],
+ long_description=long_description,
license=about["__license__"],
url=about["__uri__"],